# CVE-2019-12617: SilverStripe Priviledge escalation through cache pollution

> Attackers with limited CMS access can escalate privileges via permission cache pollution in SilverStripe.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6r58-4xgr-gm6m

## What is CVE-2019-12617?

CVE-2019-12617 is a low-severity vulnerability in Silverstripe Silverstripe, published on 26 Sep 2019. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In SilverStripe through 4.3.3, there is access escalation for CMS users with limited access through permission cache pollution.

## Which versions are affected by CVE-2019-12617?

4 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | From 4.3.0 | 4.3.5 |
| `silverstripe/framework` | Packagist | From 4.3.0 | 4.3.5 |
| `silverstripe/framework` | Packagist | From 4.4.0 | 4.4.4 |
| `silverstripe/framework` | Packagist | From 4.4.0 | 4.4.4 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2019-12617?

Upgrade silverstripe/framework to a fixed version for your release line: 4.3.5 or 4.4.4.

## Is CVE-2019-12617 being exploited?

There is no known exploitation of CVE-2019-12617 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12617 and fix it if it is affected.

What it is: CVE-2019-12617 is a low-severity vulnerability in Silverstripe Silverstripe, published on 26 Sep 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12617 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected from 4.3.0; fixed in 4.3.5
- silverstripe/framework (Packagist): affected from 4.3.0; fixed in 4.3.5
- silverstripe/framework (Packagist): affected from 4.4.0; fixed in 4.4.4
- silverstripe/framework (Packagist): affected from 4.4.0; fixed in 4.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12617/ (Markdown: https://insights.sbomify.com/CVE-2019-12617/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12617
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12617
- OSV: https://osv.dev/vulnerability/CVE-2019-12617

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12617/
Summaries are generated and may contain mistakes; the official description above is the record.
