# CVE-2019-12728: Incorrect Resource Transfer Between Spheres in Grails

> Grails framework used cleartext HTTP for SDKMan notifications, potentially allowing man-in-the-middle attacks to inject malicious code during dependency resolution.

- **Severity:** High 8.1 (`CVSS:3.0/AC:H/AV:N/A:H/C:H/I:H/PR:N/S:U/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-pmxf-4v8c-rwr7

## What is CVE-2019-12728?

CVE-2019-12728 is a high-severity vulnerability in n/a, published on 4 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grails before 3.3.10 used cleartext HTTP to resolve the SDKMan notification service. NOTE: users' apps were not resolving dependencies over cleartext HTTP.

Weakness: CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2019-12728?

2 open source packages ship an affected version, including org.grails:grails-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.grails:grails-core` | Maven | All versions | 3.3.10 |
| `org.grails:grails-core` | Maven | All versions | 3.3.10 |

Products: Grails Grails.

## How do I fix CVE-2019-12728?

Upgrade org.grails:grails-core to 3.3.10 or later.

## Is CVE-2019-12728 being exploited?

There is no known exploitation of CVE-2019-12728 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-35912](https://insights.sbomify.com/CVE-2022-35912/): Grails framework Remote Code Execution via Data Binding (critical 9.8)
- [CVE-2023-46131](https://insights.sbomify.com/CVE-2023-46131/): Grails® data binding causes JVM crash and/or DoS (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12728 and fix it if it is affected.

What it is: CVE-2019-12728 is a high-severity vulnerability in n/a, published on 4 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12728 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.grails:grails-core (Maven): affected all versions; fixed in 3.3.10
- org.grails:grails-core (Maven): affected all versions; fixed in 3.3.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12728/ (Markdown: https://insights.sbomify.com/CVE-2019-12728/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12728
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12728
- OSV: https://osv.dev/vulnerability/CVE-2019-12728

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12728/
Summaries are generated and may contain mistakes; the official description above is the record.
