CVE-2019-12747 TYPO3 Vulnerable to Insecure Deserialization

High 8.8 Published Updated

An attacker can execute arbitrary code by exploiting unsafe deserialization in TYPO3, requiring immediate upgrades.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-12747?

CVE-2019-12747 is a high-severity unsafe deserialization vulnerability in Typo3 Typo3, published on 9 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

TYPO3 8.x through 8.7.26 and 9.x through 9.5.7 allows Deserialization of Untrusted Data.

Weakness: CWE-502

Which versions are affected by CVE-2019-12747?

8 open source packages ship an affected version, including typo3/cms and typo3/cms-core. It affects 1 product.

PackageAffectedFixed in
typo3/cms PackagistFrom 8.0.08.7.27
typo3/cms PackagistFrom 8.0.08.7.27
typo3/cms PackagistFrom 9.0.09.5.8
typo3/cms PackagistFrom 9.0.09.5.8
typo3/cms-core PackagistFrom 8.0.08.7.27
typo3/cms-core PackagistFrom 8.0.08.7.27
2 more packages
typo3/cms-core PackagistFrom 9.0.09.5.8
typo3/cms-core PackagistFrom 9.0.09.5.8

Products include Typo3 Typo3.

How do I fix CVE-2019-12747?

Upgrade typo3/cms to a fixed version for your release line: 8.7.27 or 9.5.8.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2019-12747 being exploited?

There is no known exploitation of CVE-2019-12747 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-86hp-xrhj-fhpq.

Is CVE-2019-12747 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free