{"answers":{"affected":"3 open source packages ship an affected version, including parso. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-12760 exists.","fix":"Upgrade parso to 0.5.0 or later.","what":"CVE-2019-12760 is a low-severity unsafe deserialization vulnerability in n/a, published on 6 Jun 2019. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-12760 and fix it if it is affected.\n\nWhat it is: CVE-2019-12760 is a low-severity unsafe deserialization vulnerability in n/a, published on 6 Jun 2019. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-12760 exists.\n\nAffected packages and fixed versions:\n- parso (PyPI): affected all versions up to 0.4.0; no fix listed\n- parso (PyPI): affected all versions up to 0.4.0; no fix listed\n- parso (PyPI): affected all versions; fixed in 0.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-12760/ (Markdown: https://insights.sbomify.com/CVE-2019-12760/index.md)","id":"CVE-2019-12760","markdown":"https://insights.sbomify.com/CVE-2019-12760/index.md","name":"CVE-2019-12760","record":{"aliases":["DEBIAN-CVE-2019-12760","GHSA-22mf-97vh-x8rw","PYSEC-2019-109"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Python parsing library","requires_auth":"high_privilege","summary":"An attacker with write access to the cache directory can execute arbitrary code via malicious pickle files in the parso library.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"parso","vendor":"parso_project"}],"cvss":{"score":3.3,"severity":"low","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A deserialization vulnerability exists in the way parso through 0.4.0 handles grammar parsing from the cache. Cache loading relies on pickle and, provided that an evil pickle can be written to a cache grammar file and that its parsing can be triggered, this flaw leads to Arbitrary Code Execution. NOTE: This is disputed because \"the cache directory is not under control of the attacker in any common configuration.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Deserialization vulnerability exists in parso","id":"CVE-2019-12760","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2019"},"n_packages":3,"n_references":2,"next":{"headline":"Code Injection in PyXDG","id":"CVE-2019-12761"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.4.0"],"package":"parso","purl":null,"source":"GHSA-22mf-97vh-x8rw"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.4.0"],"package":"parso","purl":"pkg:pypi/parso","source":"GHSA-22mf-97vh-x8rw"},{"ecosystem":"PyPI","fixed":["0.5.0"],"introduced":["0"],"last_affected":[],"package":"parso","purl":"pkg:pypi/parso","source":"PYSEC-2019-109"}],"prev":{"headline":"Privilege escalation in Symantec Endpoint Protection Manager (SEPM), Symantec Mail Security for MS Exchange (SMSMSE)","id":"CVE-2019-12759"},"products":["n/a"],"published":"2019-06-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker with write access to the cache directory can execute arbitrary code via malicious pickle files in the parso library.","url":"https://insights.sbomify.com/CVE-2019-12760/"}