# CVE-2019-12760: Deserialization vulnerability exists in parso

> An attacker with write access to the cache directory can execute arbitrary code via malicious pickle files in the parso library.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-12760, GHSA-22mf-97vh-x8rw, PYSEC-2019-109

## What is CVE-2019-12760?

CVE-2019-12760 is a low-severity unsafe deserialization vulnerability in n/a, published on 6 Jun 2019. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A deserialization vulnerability exists in the way parso through 0.4.0 handles grammar parsing from the cache. Cache loading relies on pickle and, provided that an evil pickle can be written to a cache grammar file and that its parsing can be triggered, this flaw leads to Arbitrary Code Execution. NOTE: This is disputed because "the cache directory is not under control of the attacker in any common configuration.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2019-12760?

3 open source packages ship an affected version, including parso. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parso` | PyPI | All versions to 0.4.0 | None |
| `parso` | PyPI | All versions to 0.4.0 | None |
| `parso` | PyPI | All versions | 0.5.0 |

Products: Parso Project Parso.

## How do I fix CVE-2019-12760?

Upgrade parso to 0.5.0 or later.

## Is CVE-2019-12760 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-12760 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12760 and fix it if it is affected.

What it is: CVE-2019-12760 is a low-severity unsafe deserialization vulnerability in n/a, published on 6 Jun 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-12760 exists.

Affected packages and fixed versions:
- parso (PyPI): affected all versions up to 0.4.0; no fix listed
- parso (PyPI): affected all versions up to 0.4.0; no fix listed
- parso (PyPI): affected all versions; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12760/ (Markdown: https://insights.sbomify.com/CVE-2019-12760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12760
- OSV: https://osv.dev/vulnerability/CVE-2019-12760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12760/
Summaries are generated and may contain mistakes; the official description above is the record.
