# CVE-2019-12761: Code Injection in PyXDG

> Attackers can execute arbitrary code via crafted XML in .menu files if XDG_CONFIG_DIRS is configured, affecting applications using PyXDG.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-12761, DLA-1819-1, DLA-2727-1, GHSA-r6v3-hpxj-r8rv, PYSEC-2019-199, SNYK-PYTHON-PYXDG-174562, SUSE-SU-2022:2997-1, UBUNTU-CVE-2019-12761, USN-4700-1

## What is CVE-2019-12761?

CVE-2019-12761 is a high-severity code injection vulnerability in n/a, published on 6 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A code injection issue was discovered in PyXDG before 0.26 via crafted Python code in a Category element of a Menu XML document in a .menu file. XDG_CONFIG_DIRS must be set up to trigger xdg.Menu.parse parsing within the directory containing this file. This is due to a lack of sanitization in xdg/Menu.py before an eval call.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2019-12761?

3 open source packages ship an affected version, including pyxdg. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyxdg` | PyPI | All versions | 0.26 |
| `pyxdg` | PyPI | All versions | 0.26 |
| `pyxdg` | PyPI | All versions | 0.26 |
| `python-pyxdg` | SUSE:Enterprise Storage 6 | All versions | 0.25-150000.3.3.1 |
| `python-pyxdg` | SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 0.25-150000.3.3.1 |
| `python-pyxdg` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 0.25-150000.3.3.1 |
| `python-pyxdg` | SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 0.25-150000.3.3.1 |
| `python-pyxdg` | SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 0.25-150000.3.3.1 |
| `python-pyxdg` | SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 0.25-150000.3.3.1 |
| `python-pyxdg` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 0.25-150000.3.3.1 |
| `python-pyxdg` | SUSE:Linux Enterprise Server 15-LTSS | All versions | 0.25-150000.3.3.1 |
| `python-pyxdg` | SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 0.25-150000.3.3.1 |
| `python-pyxdg` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 0.25-150000.3.3.1 |

Products: Python Pyxdg.

## How do I fix CVE-2019-12761?

Upgrade pyxdg to 0.26 or later.

## Is CVE-2019-12761 being exploited?

There is no known exploitation of CVE-2019-12761 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-1624](https://insights.sbomify.com/CVE-2014-1624/): pyxdg Arbitrary File Overwrite via Race Condition (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12761 and fix it if it is affected.

What it is: CVE-2019-12761 is a high-severity code injection vulnerability in n/a, published on 6 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-12761 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyxdg (PyPI): affected all versions; fixed in 0.26
- pyxdg (PyPI): affected all versions; fixed in 0.26
- pyxdg (PyPI): affected all versions; fixed in 0.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12761/ (Markdown: https://insights.sbomify.com/CVE-2019-12761/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12761
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12761
- OSV: https://osv.dev/vulnerability/CVE-2019-12761

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12761/
Summaries are generated and may contain mistakes; the official description above is the record.
