# CVE-2019-12781: Django Incorrect HTTP detection with reverse-proxy connecting via HTTPS

> Attackers can bypass HTTPS redirection when specific proxy settings are enabled, allowing HTTP traffic to remain unencrypted.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2019-12781, DEBIAN-CVE-2019-12781, DLA-1842-1, GHSA-6c7v-2f49-8h26, PYSEC-2019-10, SUSE-SU-2019:2379-1, UBUNTU-CVE-2019-12781

## What is CVE-2019-12781?

CVE-2019-12781 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 1 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 1.11 before 1.11.22, 2.1 before 2.1.10, and 2.2 before 2.2.3. An HTTP request is not redirected to HTTPS when the SECURE_PROXY_SSL_HEADER and SECURE_SSL_REDIRECT settings are used, and the proxy connects to Django via HTTPS. In other words, django.http.HttpRequest.scheme has incorrect behavior when a client uses HTTP.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2019-12781?

7 open source packages ship an affected version, including django and Django. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.11 | 1.11.22 |
| `django` | PyPI | From 2.1 | 2.1.10, 2.2.3, 1.11.22 |
| `django` | PyPI | From 2.1 | 2.1.10 |
| `django` | PyPI | From 2.2 | 2.2.3 |
| `Django` | PyPI | From 1.11 | 1.11.22 |
| `Django` | PyPI | From 2.1 | 2.1.10 |
| `Django` | PyPI | From 2.2 | 2.2.3 |
| `python-Django` | SUSE:OpenStack Cloud 7 | All versions | 1.8.19-3.18.1 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Djangoproject Django.

## How do I fix CVE-2019-12781?

Upgrade django to a fixed version for your release line: 1.11.22, 2.1.10 or 2.2.3.

## Is CVE-2019-12781 being exploited?

There is no known exploitation of CVE-2019-12781 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12781 and fix it if it is affected.

What it is: CVE-2019-12781 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 1 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12781 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 1.11; fixed in 1.11.22
- django (PyPI): affected from 2.1; fixed in 2.1.10, 2.2.3, 1.11.22
- django (PyPI): affected from 2.1; fixed in 2.1.10
- django (PyPI): affected from 2.2; fixed in 2.2.3
- Django (PyPI): affected from 1.11; fixed in 1.11.22
- Django (PyPI): affected from 2.1; fixed in 2.1.10
- Django (PyPI): affected from 2.2; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12781/ (Markdown: https://insights.sbomify.com/CVE-2019-12781/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12781
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12781
- OSV: https://osv.dev/vulnerability/CVE-2019-12781

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12781/
Summaries are generated and may contain mistakes; the official description above is the record.
