CVE-2019-12814 Deserialization of untrusted data in FasterXML jackson-databind
Attackers can read arbitrary local files on servers using Jackson databind if Default Typing is enabled and JDOM is present.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-12814?
CVE-2019-12814 is a medium-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 19 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A Polymorphic Typing issue was discovered in FasterXML jackson-databind 2.x through 2.9.9. When Default Typing is enabled (either globally or for a specific property) for an externally exposed JSON endpoint and the service has JDOM 1.x or 2.x jar in the classpath, an attacker can send a specifically crafted JSON message that allows them to read arbitrary local files on the server.
Weakness: CWE-502
Which versions are affected by CVE-2019-12814?
8 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
com.fasterxml.jackson.core:jackson-databind Maven | From 2.0.0 | 2.6.7.3 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.0.0 | 2.6.7.3 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.7.0 | 2.7.9.6 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.7.0 | 2.7.9.6 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.8.0 | 2.8.11.4 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.8.0 | 2.8.11.4 |
2 more packages
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.9.1 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.9.1 |
Products include Debian Debian Linux, Fasterxml Jackson-Databind.
How do I fix CVE-2019-12814?
Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.6.7.3, 2.7.9.6, 2.8.11.4 or 2.9.9.1.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2019-12814 being exploited?
There is no known exploitation of CVE-2019-12814 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-NN88858, DEBIAN-CVE-2019-12814, GHSA-cmfg-87vq-g5g4, UBUNTU-CVE-2019-12814.