# CVE-2019-12814: Deserialization of untrusted data in FasterXML jackson-databind

> Attackers can read arbitrary local files on servers using Jackson databind if Default Typing is enabled and JDOM is present.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2019
- **Updated:** 27 Aug 2025
- **Also known as:** CLEANSTART-2026-NN88858, DEBIAN-CVE-2019-12814, GHSA-cmfg-87vq-g5g4, UBUNTU-CVE-2019-12814

## What is CVE-2019-12814?

CVE-2019-12814 is a medium-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 19 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Polymorphic Typing issue was discovered in FasterXML jackson-databind 2.x through 2.9.9. When Default Typing is enabled (either globally or for a specific property) for an externally exposed JSON endpoint and the service has JDOM 1.x or 2.x jar in the classpath, an attacker can send a specifically crafted JSON message that allows them to read arbitrary local files on the server.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2019-12814?

8 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.0.0 | 2.6.7.3 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.0.0 | 2.6.7.3 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.7.0 | 2.7.9.6 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.7.0 | 2.7.9.6 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.8.0 | 2.8.11.4 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.8.0 | 2.8.11.4 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.9.1 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.9.1 |

Products: Debian Debian Linux, Fasterxml Jackson-Databind.

## How do I fix CVE-2019-12814?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.6.7.3, 2.7.9.6, 2.8.11.4 or 2.9.9.1.

## Is CVE-2019-12814 being exploited?

There is no known exploitation of CVE-2019-12814 in the wild and no public exploit code.

Public exploit code:

- CVE-2019-12814:Jackson JDOM XSLTransformer Gadget (github_poc): https://github.com/Al1ex/CVE-2019-12814

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12814 and fix it if it is affected.

What it is: CVE-2019-12814 is a medium-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 19 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12814 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.0.0; fixed in 2.6.7.3
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.0.0; fixed in 2.6.7.3
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.7.0; fixed in 2.7.9.6
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.7.0; fixed in 2.7.9.6
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.8.0; fixed in 2.8.11.4
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.8.0; fixed in 2.8.11.4
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.9.1
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12814/ (Markdown: https://insights.sbomify.com/CVE-2019-12814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12814
- OSV: https://osv.dev/vulnerability/CVE-2019-12814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12814/
Summaries are generated and may contain mistakes; the official description above is the record.
