# CVE-2019-12887: LinOTP replay vulnerability with auto resynchronization enabled for TOTP token

> Attackers can bypass authentication controls in LinOTP, potentially gaining unauthorized access to the system.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** CVE-2019-12888, GHSA-rqg8-xjp2-pg9w, PYSEC-2019-103

## What is CVE-2019-12887?

CVE-2019-12887 is a high-severity authentication bypass vulnerability in n/a, published on 27 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

KeyIdentity LinOTP before 2.10.5.3 has Incorrect Access Control (issue 1 of 2).

Weakness: CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2019-12887?

3 open source packages ship an affected version, including linotp and LinOTP. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `linotp` | PyPI | All versions | 2.11.1 |
| `linotp` | PyPI | All versions | 2.11.1 |
| `LinOTP` | PyPI | All versions | 2.11.1 |

Products: Keyidentity Linotp.

## How do I fix CVE-2019-12887?

Upgrade linotp to 2.11.1 or later.

## Is CVE-2019-12887 being exploited?

There is no known exploitation of CVE-2019-12887 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12887 and fix it if it is affected.

What it is: CVE-2019-12887 is a high-severity authentication bypass vulnerability in n/a, published on 27 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12887 in the wild and no public exploit code.

Affected packages and fixed versions:
- linotp (PyPI): affected all versions; fixed in 2.11.1
- linotp (PyPI): affected all versions; fixed in 2.11.1
- LinOTP (PyPI): affected all versions; fixed in 2.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12887/ (Markdown: https://insights.sbomify.com/CVE-2019-12887/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12887
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12887
- OSV: https://osv.dev/vulnerability/CVE-2019-12887

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12887/
Summaries are generated and may contain mistakes; the official description above is the record.
