# CVE-2019-12935: Shopware Cross-site Scripting Vulnerability

> Cross-site scripting in Shopware allows attackers to inject scripts via query strings, potentially leading to session hijacking or code execution.

- **Severity:** High 7.4 (`CVSS:3.0/AC:L/AV:N/A:N/C:H/I:N/PR:N/S:C/UI:R`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-8qxh-hcr9-2379

## What is CVE-2019-12935?

CVE-2019-12935 is a high-severity cross-site scripting vulnerability in Shopware Shopware, published on 23 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Shopware before 5.5.8 has XSS via the Query String to the backend/Login or backend/Login/load/ URI.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-12935?

2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/shopware` | Packagist | All versions | 5.5.8 |
| `shopware/shopware` | Packagist | All versions | 5.5.8 |

Products: Shopware Shopware.

## How do I fix CVE-2019-12935?

Upgrade shopware/shopware to 5.5.8 or later.

## Is CVE-2019-12935 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-12935 exists.

Public exploit code:

- Shopware < 5.5.8 - Cross-Site Scripting (nuclei): http/cves/2019/CVE-2019-12935.yaml

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12935 and fix it if it is affected.

What it is: CVE-2019-12935 is a high-severity cross-site scripting vulnerability in Shopware Shopware, published on 23 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-12935 exists.

Affected packages and fixed versions:
- shopware/shopware (Packagist): affected all versions; fixed in 5.5.8
- shopware/shopware (Packagist): affected all versions; fixed in 5.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12935/ (Markdown: https://insights.sbomify.com/CVE-2019-12935/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12935
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12935
- OSV: https://osv.dev/vulnerability/CVE-2019-12935

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12935/
Summaries are generated and may contain mistakes; the official description above is the record.
