# CVE-2019-13014: Little Snitch versions 4.4.0 fixes a vulnerability in a privileged helper tool.


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6v3c-8pw3-vqqp

## What is CVE-2019-13014?

CVE-2019-13014 is a medium-severity vulnerability in Little Snitch, published on 23 Aug 2019. 

### Official description

Little Snitch versions 4.4.0 fixes a vulnerability in a privileged helper tool. However, the operating system may have made a copy of the privileged helper which is not removed or updated immediately. Computers may therefore still be vulnerable after upgrading to 4.4.0. Version 4.4.1 fixes this issue by removing the operating system's copy during the upgrade.

Weakness: CWE-459 (Incomplete Cleanup), CWE-264

## Which versions are affected by CVE-2019-13014?

It affects 1 product.


Products: Obdev Little Snitch.

## How do I fix CVE-2019-13014?

No fix has been published for CVE-2019-13014 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-13014 being exploited?

There is no known exploitation of CVE-2019-13014 in the wild and no public exploit code.

## Other vulnerabilities in Little Snitch

- [CVE-2020-13095](https://insights.sbomify.com/CVE-2020-13095/): Privilege escalation in Little Snitch (high 8.8)
- [CVE-2016-8661](https://insights.sbomify.com/CVE-2016-8661/): Memory corruption in Little Snitch version 3.0 through 3.6.1 (high 8.4)
- [CVE-2017-2675](https://insights.sbomify.com/CVE-2017-2675/): Privilege escalation in Little Snitch (high 7.8)
- [CVE-2019-13013](https://insights.sbomify.com/CVE-2019-13013/): Privilege escalation in Little Snitch (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13014 and fix it if it is affected.

What it is: CVE-2019-13014 is a medium-severity vulnerability in Little Snitch, published on 23 Aug 2019. 
Exploitation: There is no known exploitation of CVE-2019-13014 in the wild and no public exploit code.

Affected product: Little Snitch. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13014/ (Markdown: https://insights.sbomify.com/CVE-2019-13014/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13014
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13014
- OSV: https://osv.dev/vulnerability/CVE-2019-13014

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13014/
Summaries are generated and may contain mistakes; the official description above is the record.
