{"answers":{"affected":"It affects 5 products.","exploited":"There is no known exploitation of CVE-2019-13050 in the wild and no public exploit code.","fix":"Change a configuration setting.","what":"CVE-2019-13050 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 29 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-13050 and fix it if it is affected.\n\nWhat it is: CVE-2019-13050 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 29 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-13050 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-13050/ (Markdown: https://insights.sbomify.com/CVE-2019-13050/index.md)","id":"CVE-2019-13050","markdown":"https://insights.sbomify.com/CVE-2019-13050/index.md","name":"CVE-2019-13050","record":{"aliases":["GHSA-ch5h-mpfr-fhxh","SUSE-SU-2019:2006-1","SUSE-SU-2019:2480-1","UBUNTU-CVE-2019-13050","USN-5431-1","openSUSE-SU-2019:1917-1"],"analysis":{"component_type":"server_software","fix_type":"configuration_change","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"SKS keyserver","requires_auth":"none","summary":"Retrieving data from SKS keyserver network causes persistent denial of service via certificate spamming, requiring users to avoid SKS hosts in GnuPG config.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"traffix_signaling_delivery_controller","vendor":"f5"},{"product":"fedora","vendor":"fedoraproject"},{"product":"gnupg","vendor":"gnupg"},{"product":"leap","vendor":"opensuse"},{"product":"sks_keyserver","vendor":"sks_keyserver_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Interaction between the sks-keyserver code through 1.2.0 of the SKS keyserver network, and GnuPG through 2.2.16, makes it risky to have a GnuPG keyserver configuration line referring to a host on the SKS keyserver network. Retrieving data from this network may cause a persistent denial of service, because of a Certificate Spamming Attack.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP4","SUSE:Linux Enterprise Module for Basesystem 15","SUSE:Linux Enterprise Module for Basesystem 15 SP1","SUSE:Linux Enterprise Server 12 SP4","SUSE:Linux Enterprise Server for SAP Applications 12 SP4","openSUSE:Leap 15.0","openSUSE:Leap 15.1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2019-13050","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:leap"],"type":"denial_of_service","year":"2019"},"n_packages":7,"n_references":11,"next":{"headline":"Pi-Hole 4.3 allows Command Injection.","id":"CVE-2019-13051"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP4","fixed":["2.0.24-9.8.1"],"introduced":["0"],"last_affected":[],"package":"gpg2","purl":"pkg:rpm/suse/gpg2\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP4","source":"SUSE-SU-2019:2480-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15","fixed":["2.2.5-4.11.1"],"introduced":["0"],"last_affected":[],"package":"gpg2","purl":"pkg:rpm/suse/gpg2\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015","source":"SUSE-SU-2019:2006-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP1","fixed":["2.2.5-4.11.1"],"introduced":["0"],"last_affected":[],"package":"gpg2","purl":"pkg:rpm/suse/gpg2\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP1","source":"SUSE-SU-2019:2006-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP4","fixed":["2.0.24-9.8.1"],"introduced":["0"],"last_affected":[],"package":"gpg2","purl":"pkg:rpm/suse/gpg2\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP4","source":"SUSE-SU-2019:2480-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP4","fixed":["2.0.24-9.8.1"],"introduced":["0"],"last_affected":[],"package":"gpg2","purl":"pkg:rpm/suse/gpg2\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP4","source":"SUSE-SU-2019:2480-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["2.2.5-lp151.6.3.1"],"introduced":["0"],"last_affected":[],"package":"gpg2","purl":"pkg:rpm/opensuse/gpg2\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:1917-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["2.2.5-lp151.6.3.1"],"introduced":["0"],"last_affected":[],"package":"gpg2","purl":"pkg:rpm/opensuse/gpg2\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2019:1917-1"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2019-13049"},"products":["n/a"],"published":"2019-06-29","related":[{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2018-20657","kev_date_added":null,"published":"2019-01-02"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2015-5738","kev_date_added":null,"published":"2016-07-26"},{"cvss_score":5.5,"headline":"Denial of service in n/a","id":"CVE-2018-20002","kev_date_added":null,"published":"2018-12-10"},{"cvss_score":4.8,"headline":"Code injection in Traffix SDC","id":"CVE-2022-27662","kev_date_added":null,"published":"2022-05-05"},{"cvss_score":4.8,"headline":"Cross-site scripting in Traffix SDC","id":"CVE-2022-27880","kev_date_added":null,"published":"2022-05-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Retrieving data from SKS keyserver network causes persistent denial of service via certificate spamming, requiring users to avoid SKS hosts in GnuPG config.","url":"https://insights.sbomify.com/CVE-2019-13050/"}