CVE-2019-13115 Integer overflow in n/a

High 8.1 Published Updated

A remote attacker controlling an SSH server can trigger an integer overflow in libssh2 clients, leading to information disclosure or denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-13115?

CVE-2019-13115 is a high-severity vulnerability in Debian Debian Linux, published on 16 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In libssh2 before 1.9.0, kex_method_diffie_hellman_group_exchange_sha256_key_exchange in kex.c has an integer overflow that could lead to an out-of-bounds read in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server. This is related to an _libssh2_check_length mistake, and is different from the various issues fixed in 1.8.1, such as CVE-2019-3855.

Weakness: CWE-190, CWE-125

Which versions are affected by CVE-2019-13115?

It affects 7 products.

Products include Debian Debian Linux, F5 Traffix Systems Signaling Delivery Controller, Fedoraproject Fedora, Libssh2 Libssh2, Netapp Cloud Backup, Netapp E-Series Santricity Os Controller and 1 more.

How do I fix CVE-2019-13115?

Upgrade to a fixed version.

Is CVE-2019-13115 being exploited?

There is no known exploitation of CVE-2019-13115 in the wild and no public exploit code.

Public exploit code: 2 proofs of concept on GitHub.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2019-13115, DEBIAN-CVE-2019-13115, GHSA-98vm-qgxx-5rjm, UBUNTU-CVE-2019-13115.

Is CVE-2019-13115 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free