{"answers":{"affected":"It affects 7 products.","exploited":"There is no known exploitation of CVE-2019-13115 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-13115 is a high-severity vulnerability in Debian Debian Linux, published on 16 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-13115 and fix it if it is affected.\n\nWhat it is: CVE-2019-13115 is a high-severity vulnerability in Debian Debian Linux, published on 16 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-13115 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-13115/ (Markdown: https://insights.sbomify.com/CVE-2019-13115/index.md)","id":"CVE-2019-13115","markdown":"https://insights.sbomify.com/CVE-2019-13115/index.md","name":"CVE-2019-13115","record":{"aliases":["ALPINE-CVE-2019-13115","DEBIAN-CVE-2019-13115","GHSA-98vm-qgxx-5rjm","UBUNTU-CVE-2019-13115"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"libssh2 library","requires_auth":"none","summary":"A remote attacker controlling an SSH server can trigger an integer overflow in libssh2 clients, leading to information disclosure or denial of service.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"traffix_systems_signaling_delivery_controller","vendor":"f5"},{"product":"fedora","vendor":"fedoraproject"},{"product":"libssh2","vendor":"libssh2"},{"product":"cloud_backup","vendor":"netapp"},{"product":"e-series_santricity_os_controller","vendor":"netapp"},{"product":"ontap_select_deploy_administration_utility","vendor":"netapp"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"},{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"In libssh2 before 1.9.0, kex_method_diffie_hellman_group_exchange_sha256_key_exchange in kex.c has an integer overflow that could lead to an out-of-bounds read in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server. This is related to an _libssh2_check_length mistake, and is different from the various issues fixed in 1.8.1, such as CVE-2019-3855.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2019-10-03","github_poc":2,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2019-10-03T17:26:08Z","kind":"github_poc","ref":"https://github.com/viz27/Libssh2-Exploit","stars":1,"title":"Create an exploit to libssh2 vulnerabulity described in CVE-2019-13115"},{"date":"2019-10-03T17:58:03Z","kind":"github_poc","ref":"https://github.com/CSSProject/libssh2-Exploit","stars":0,"title":"Create an exploit to libssh2 vulnerabulity described in CVE-2019-13115"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2019-13115","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","netapp:cloud_backup","netapp:e-series_santricity_os_controller","netapp:ontap_select_deploy_administration_utility"],"type":"integer_overflow","year":"2019"},"n_packages":0,"n_references":15,"next":{"headline":"Mulesoft Mule Unsafe Deserialization","id":"CVE-2019-13116"},"packages":[],"prev":{"headline":"Null dereference in n/a","id":"CVE-2019-13114"},"products":["n/a"],"published":"2019-07-16","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A remote attacker controlling an SSH server can trigger an integer overflow in libssh2 clients, leading to information disclosure or denial of service.","url":"https://insights.sbomify.com/CVE-2019-13115/"}