# CVE-2019-13115: Integer overflow in n/a

> A remote attacker controlling an SSH server can trigger an integer overflow in libssh2 clients, leading to information disclosure or denial of service.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2019-13115, DEBIAN-CVE-2019-13115, GHSA-98vm-qgxx-5rjm, UBUNTU-CVE-2019-13115

## What is CVE-2019-13115?

CVE-2019-13115 is a high-severity vulnerability in Debian Debian Linux, published on 16 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In libssh2 before 1.9.0, kex_method_diffie_hellman_group_exchange_sha256_key_exchange in kex.c has an integer overflow that could lead to an out-of-bounds read in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server. This is related to an _libssh2_check_length mistake, and is different from the various issues fixed in 1.8.1, such as CVE-2019-3855.

Weakness: CWE-190 (Integer Overflow or Wraparound), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2019-13115?

It affects 7 products.


Products: Debian Debian Linux, F5 Traffix Systems Signaling Delivery Controller, Fedoraproject Fedora, Libssh2 Libssh2, Netapp Cloud Backup, Netapp E-Series Santricity Os Controller, Netapp Ontap Select Deploy Administration Utility.

## How do I fix CVE-2019-13115?

Upgrade to a fixed version.

## Is CVE-2019-13115 being exploited?

There is no known exploitation of CVE-2019-13115 in the wild and no public exploit code.

Public exploit code:

- Create an exploit to libssh2 vulnerabulity described in CVE-2019-13115 (github_poc): https://github.com/viz27/Libssh2-Exploit
- Create an exploit to libssh2 vulnerabulity described in CVE-2019-13115 (github_poc): https://github.com/CSSProject/libssh2-Exploit

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13115 and fix it if it is affected.

What it is: CVE-2019-13115 is a high-severity vulnerability in Debian Debian Linux, published on 16 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-13115 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13115/ (Markdown: https://insights.sbomify.com/CVE-2019-13115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13115
- OSV: https://osv.dev/vulnerability/CVE-2019-13115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13115/
Summaries are generated and may contain mistakes; the official description above is the record.
