# CVE-2019-13117: Uninitialized read in Nokogiri gem

> An attacker can read uninitialized stack memory via crafted XSLT number formats, potentially disclosing sensitive data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2019
- **Updated:** 28 May 2026
- **Also known as:** ALPINE-CVE-2019-13117, DEBIAN-CVE-2019-13117, GHSA-4hm9-844j-jmxp, JLSEC-2026-578, UBUNTU-CVE-2019-13117

## What is CVE-2019-13117?

CVE-2019-13117 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 1 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In numbers.c in libxslt 1.1.33, an xsl:number with certain format strings could lead to a uninitialized read in xsltNumberFormatInsertNumbers. This could allow an attacker to discern whether a byte on the stack contains the characters A, a, I, i, or 0, or any other character.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2019-13117?

2 open source packages ship an affected version, including nokogiri. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.10.5 |
| `nokogiri` | RubyGems | All versions | 1.10.5 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Opensuse Leap, Oracle Openjdk, Xmlsoft Libxslt.

## How do I fix CVE-2019-13117?

Upgrade nokogiri to 1.10.5 or later.

## Is CVE-2019-13117 being exploited?

There is no known exploitation of CVE-2019-13117 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13117 and fix it if it is affected.

What it is: CVE-2019-13117 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 1 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-13117 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.10.5
- nokogiri (RubyGems): affected all versions; fixed in 1.10.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13117/ (Markdown: https://insights.sbomify.com/CVE-2019-13117/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13117
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13117
- OSV: https://osv.dev/vulnerability/CVE-2019-13117

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13117/
Summaries are generated and may contain mistakes; the official description above is the record.
