# CVE-2019-13126: Integer Overflow or Wraparound in NATS Server

> A remote attacker can crash the NATS server via a crafted request causing an integer overflow, requiring authentication if enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jp4j-47f9-2vc3, GO-2022-0852

## What is CVE-2019-13126?

CVE-2019-13126 is a high-severity vulnerability in n/a, published on 29 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An integer overflow in NATS Server before 2.0.2 allows a remote attacker to crash the server by sending a crafted request. If authentication is enabled, then the remote attacker must have first authenticated.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2019-13126?

4 open source packages ship an affected version, including github.com/nats-io/nats-server/v2 and github.com/nats-io/nats-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.2.0 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.2.0 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.2.0 |
| `github.com/nats-io/nats-server` | Go | All versions | None |

Products: Linuxfoundation Nats-Server.

## How do I fix CVE-2019-13126?

Upgrade github.com/nats-io/nats-server/v2 to 2.2.0 or later.

## Is CVE-2019-13126 being exploited?

There is no known exploitation of CVE-2019-13126 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2022-24450](https://insights.sbomify.com/CVE-2022-24450/): Incorrect Authorization in NATS nats-server (high 8.8)
- [CVE-2026-33216](https://insights.sbomify.com/CVE-2026-33216/): NATS has MQTT plaintext password disclosure (high 8.6)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13126 and fix it if it is affected.

What it is: CVE-2019-13126 is a high-severity vulnerability in n/a, published on 29 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-13126 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.2.0
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.2.0
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.2.0
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13126/ (Markdown: https://insights.sbomify.com/CVE-2019-13126/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13126
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13126
- OSV: https://osv.dev/vulnerability/CVE-2019-13126

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13126/
Summaries are generated and may contain mistakes; the official description above is the record.
