{"answers":{"affected":"2 open source packages ship an affected version, including mxgraph. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-13127 in the wild and no public exploit code.","fix":"Upgrade mxgraph to 4.0.1 or later.","what":"CVE-2019-13127 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-13127 and fix it if it is affected.\n\nWhat it is: CVE-2019-13127 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-13127 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mxgraph (npm): affected all versions; fixed in 4.0.1\n- mxgraph (npm): affected all versions; fixed in 4.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-13127/ (Markdown: https://insights.sbomify.com/CVE-2019-13127/index.md)","id":"CVE-2019-13127","markdown":"https://insights.sbomify.com/CVE-2019-13127/index.md","name":"CVE-2019-13127","record":{"aliases":["GHSA-xm59-jvxm-cp3v"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Confluence draw.io plugin","requires_auth":"none","summary":"Cross-site scripting vulnerability in the draw.io Diagrams plugin for Confluence allows attackers to execute arbitrary scripts via improper input validation.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"draw.io_diagrams","vendor":"draw"},{"product":"mxgraph","vendor":"jgraph"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An issue was discovered in mxGraph through 4.0.0, related to the \"draw.io Diagrams\" plugin before 8.3.14 for Confluence and other products. Improper input validation/sanitization of a color field leads to XSS. This is associated with javascript/examples/grapheditor/www/js/Dialogs.js.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"mxGraph vulnerable to cross-site scripting in color field","id":"CVE-2019-13127","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Command injection in n/a","id":"CVE-2019-13128"},"packages":[{"ecosystem":"npm","fixed":["4.0.1"],"introduced":["0"],"last_affected":[],"package":"mxgraph","purl":null,"source":"GHSA-xm59-jvxm-cp3v"},{"ecosystem":"npm","fixed":["4.0.1"],"introduced":["0"],"last_affected":[],"package":"mxgraph","purl":"pkg:npm/mxgraph","source":"GHSA-xm59-jvxm-cp3v"}],"prev":{"headline":"Integer Overflow or Wraparound in NATS Server","id":"CVE-2019-13126"},"products":["n/a"],"published":"2019-07-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in the draw.io Diagrams plugin for Confluence allows attackers to execute arbitrary scripts via improper input validation.","url":"https://insights.sbomify.com/CVE-2019-13127/"}