# CVE-2019-13146: field_test gem contains injection vulnerability

> The field_test gem allows unvalidated input to return arbitrary values, potentially enabling downstream vulnerabilities like SQL injection or XSS in dependent applications.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-wg9m-gw3h-hg83

## What is CVE-2019-13146?

CVE-2019-13146 is a medium-severity vulnerability in n/a, published on 9 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The field_test gem 0.3.0 for Ruby has unvalidated input. A method call that is expected to return a value from a certain set of inputs can be made to return any input, which can be dangerous depending on how applications use it. If an application treats arbitrary variants as trusted, this can lead to a variety of potential vulnerabilities like SQL injection or cross-site scripting (XSS).

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2019-13146?

2 open source packages ship an affected version, including field_test. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `field_test` | RubyGems | From 0.3.0 | 0.3.1 |
| `field_test` | RubyGems | From 0.3.0 | 0.3.1 |

Products: Field Test Project Field Test.

## How do I fix CVE-2019-13146?

Upgrade field_test to 0.3.1 or later.

## Is CVE-2019-13146 being exploited?

There is no known exploitation of CVE-2019-13146 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-16252](https://insights.sbomify.com/CVE-2020-16252/): Field Test CSRF vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13146 and fix it if it is affected.

What it is: CVE-2019-13146 is a medium-severity vulnerability in n/a, published on 9 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-13146 in the wild and no public exploit code.

Affected packages and fixed versions:
- field_test (RubyGems): affected from 0.3.0; fixed in 0.3.1
- field_test (RubyGems): affected from 0.3.0; fixed in 0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13146/ (Markdown: https://insights.sbomify.com/CVE-2019-13146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13146
- OSV: https://osv.dev/vulnerability/CVE-2019-13146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13146/
Summaries are generated and may contain mistakes; the official description above is the record.
