CVE-2019-13209 Rancher Vulnerable to Cross-site Request Forgery (CSRF)
Attackers can hijack websockets to execute commands on Kubernetes clusters using a logged-in victim's permissions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-13209?
CVE-2019-13209 is a medium-severity vulnerability in n/a, published on 4 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Rancher 2 through 2.2.4 is vulnerable to a Cross-Site Websocket Hijacking attack that allows an exploiter to gain access to clusters managed by Rancher. The attack requires a victim to be logged into a Rancher server, and then to access a third-party site hosted by the exploiter. Once that is accomplished, the exploiter is able to execute commands against the cluster's Kubernetes API with the permissions and identity of the victim.
Weakness: CWE-79
Which versions are affected by CVE-2019-13209?
7 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rancher/rancher Go | All versions | 2.2.5-rc6.0.20190621200032-0ddffe484adc+incompatible |
github.com/rancher/rancher Go | From 2.0.0 | 2.0.16 |
github.com/rancher/rancher Go | From 2.0.0 | 2.0.16 |
github.com/rancher/rancher Go | From 2.1.0 | 2.1.11 |
github.com/rancher/rancher Go | From 2.1.0 | 2.1.11 |
github.com/rancher/rancher Go | From 2.2.0 | 2.2.5 |
1 more packages
github.com/rancher/rancher Go | From 2.2.0 | 2.2.5 |
Products include Suse Rancher.
How do I fix CVE-2019-13209?
Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.2.5-rc6.0.20190621200032-0ddffe484adc+incompatible, 2.0.16, 2.1.11 or 2.2.5.
Is CVE-2019-13209 being exploited?
There is no known exploitation of CVE-2019-13209 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2023-22647 Rancher vulnerable to Privilege Escalation via manipulation of Secrets
- CVE-2023-22651 Rancher Webhook is misconfigured during upgrade process
- CVE-2022-43757 Rancher: Exposure of sensitive fields
- CVE-2021-36782 Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object
- CVE-2021-36783 Rancher: Failure to properly sanitize credentials in cluster template answers
Sources
Also known as GHSA-xhg2-rvm8-w2jh, GO-2022-0755.