# CVE-2019-13209: Rancher Vulnerable to Cross-site Request Forgery (CSRF)

> Attackers can hijack websockets to execute commands on Kubernetes clusters using a logged-in victim's permissions.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-xhg2-rvm8-w2jh, GO-2022-0755

## What is CVE-2019-13209?

CVE-2019-13209 is a medium-severity vulnerability in n/a, published on 4 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Rancher 2 through 2.2.4 is vulnerable to a Cross-Site Websocket Hijacking attack that allows an exploiter to gain access to clusters managed by Rancher. The attack requires a victim to be logged into a Rancher server, and then to access a third-party site hosted by the exploiter. Once that is accomplished, the exploiter is able to execute commands against the cluster's Kubernetes API with the permissions and identity of the victim.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-13209?

7 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | All versions | 2.2.5-rc6.0.20190621200032-0ddffe484adc+incompatible |
| `github.com/rancher/rancher` | Go | From 2.0.0 | 2.0.16 |
| `github.com/rancher/rancher` | Go | From 2.0.0 | 2.0.16 |
| `github.com/rancher/rancher` | Go | From 2.1.0 | 2.1.11 |
| `github.com/rancher/rancher` | Go | From 2.1.0 | 2.1.11 |
| `github.com/rancher/rancher` | Go | From 2.2.0 | 2.2.5 |
| `github.com/rancher/rancher` | Go | From 2.2.0 | 2.2.5 |

Products: Suse Rancher.

## How do I fix CVE-2019-13209?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.2.5-rc6.0.20190621200032-0ddffe484adc+incompatible, 2.0.16, 2.1.11 or 2.2.5.

## Is CVE-2019-13209 being exploited?

There is no known exploitation of CVE-2019-13209 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-22647](https://insights.sbomify.com/CVE-2023-22647/): Rancher vulnerable to Privilege Escalation via manipulation of Secrets (critical 9.9)
- [CVE-2023-22651](https://insights.sbomify.com/CVE-2023-22651/): Rancher Webhook is misconfigured during upgrade process (critical 9.9)
- [CVE-2022-43757](https://insights.sbomify.com/CVE-2022-43757/): Rancher: Exposure of sensitive fields (critical 9.9)
- [CVE-2021-36782](https://insights.sbomify.com/CVE-2021-36782/): Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object (critical 9.9)
- [CVE-2021-36783](https://insights.sbomify.com/CVE-2021-36783/): Rancher: Failure to properly sanitize credentials in cluster template answers (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13209 and fix it if it is affected.

What it is: CVE-2019-13209 is a medium-severity vulnerability in n/a, published on 4 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-13209 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected all versions; fixed in 2.2.5-rc6.0.20190621200032-0ddffe484adc+incompatible
- github.com/rancher/rancher (Go): affected from 2.0.0; fixed in 2.0.16
- github.com/rancher/rancher (Go): affected from 2.0.0; fixed in 2.0.16
- github.com/rancher/rancher (Go): affected from 2.1.0; fixed in 2.1.11
- github.com/rancher/rancher (Go): affected from 2.1.0; fixed in 2.1.11
- github.com/rancher/rancher (Go): affected from 2.2.0; fixed in 2.2.5
- github.com/rancher/rancher (Go): affected from 2.2.0; fixed in 2.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13209/ (Markdown: https://insights.sbomify.com/CVE-2019-13209/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13209
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13209
- OSV: https://osv.dev/vulnerability/CVE-2019-13209

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13209/
Summaries are generated and may contain mistakes; the official description above is the record.
