# CVE-2019-13234: XSS in search engine

> Cross-site scripting vulnerability in the Alkacon OpenCms Apollo Template search engine allows attackers to inject malicious scripts.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fxp8-7h5w-h235

## What is CVE-2019-13234?

CVE-2019-13234 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In the Alkacon OpenCms Apollo Template 10.5.4 and 10.5.5, there is XSS in the search engine.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-13234?

2 open source packages ship an affected version, including org.opencms:opencms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencms:opencms-core` | Maven | All versions | 11.0.1 |
| `org.opencms:opencms-core` | Maven | All versions | 11.0.1 |

Products: Alkacon Opencms Apollo Template.

## How do I fix CVE-2019-13234?

Upgrade org.opencms:opencms-core to 11.0.1 or later.

## Is CVE-2019-13234 being exploited?

There is no known exploitation of CVE-2019-13234 in the wild and no public exploit code.

Public exploit code:

- Alkacon OpenCMS 10.5.x - Cross-Site Scripting (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2019-13235](https://insights.sbomify.com/CVE-2019-13235/): XSS in login form (medium 6.1)
- [CVE-2019-13237](https://insights.sbomify.com/CVE-2019-13237/): Local file inclusion allows unauthorized access to internal resources in Alkacon OpenCms (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13234 and fix it if it is affected.

What it is: CVE-2019-13234 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-13234 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencms:opencms-core (Maven): affected all versions; fixed in 11.0.1
- org.opencms:opencms-core (Maven): affected all versions; fixed in 11.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13234/ (Markdown: https://insights.sbomify.com/CVE-2019-13234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13234
- OSV: https://osv.dev/vulnerability/CVE-2019-13234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13234/
Summaries are generated and may contain mistakes; the official description above is the record.
