# CVE-2019-13237: Local file inclusion allows unauthorized access to internal resources in Alkacon OpenCms

> Attackers can exploit Local File Inclusion vulnerabilities in multiple JSP resources to access sensitive server files.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-36hf-6hp2-9g4c

## What is CVE-2019-13237?

CVE-2019-13237 is a medium-severity path traversal vulnerability in n/a, published on 27 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Alkacon OpenCms 10.5.4 and 10.5.5, there are multiple resources vulnerable to Local File Inclusion that allow an attacker to access server resources: clearhistory.jsp, convertxml.jsp, group_new.jsp, loginmessage.jsp, xmlcontentrepair.jsp, and /system/workplace/admin/history/settings/index.jsp.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-13237?

2 open source packages ship an affected version, including org.opencms:opencms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencms:opencms-core` | Maven | All versions | 11.0.1 |
| `org.opencms:opencms-core` | Maven | All versions | 11.0.1 |

Products: Alkacon Opencms Apollo Template.

## How do I fix CVE-2019-13237?

Upgrade org.opencms:opencms-core to 11.0.1 or later.

## Is CVE-2019-13237 being exploited?

There is no known exploitation of CVE-2019-13237 in the wild and no public exploit code.

Public exploit code:

- Alkacon OpenCMS 10.5.x - Local File inclusion (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2019-13234](https://insights.sbomify.com/CVE-2019-13234/): XSS in search engine (medium 6.1)
- [CVE-2019-13235](https://insights.sbomify.com/CVE-2019-13235/): XSS in login form (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13237 and fix it if it is affected.

What it is: CVE-2019-13237 is a medium-severity path traversal vulnerability in n/a, published on 27 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-13237 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencms:opencms-core (Maven): affected all versions; fixed in 11.0.1
- org.opencms:opencms-core (Maven): affected all versions; fixed in 11.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13237/ (Markdown: https://insights.sbomify.com/CVE-2019-13237/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13237
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13237
- OSV: https://osv.dev/vulnerability/CVE-2019-13237

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13237/
Summaries are generated and may contain mistakes; the official description above is the record.
