{"answers":{"affected":"2 open source packages ship an affected version, including strong_password. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-13354 in the wild and no public exploit code.","fix":"Upgrade strong_password to 0.0.8 or later.","what":"CVE-2019-13354 is a critical code injection vulnerability in n/a, published on 8 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-13354 and fix it if it is affected.\n\nWhat it is: CVE-2019-13354 is a critical code injection vulnerability in n/a, published on 8 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-13354 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- strong_password (RubyGems): affected from 0.0.7; fixed in 0.0.8\n- strong_password (RubyGems): affected from 0.0.7; fixed in 0.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-13354/ (Markdown: https://insights.sbomify.com/CVE-2019-13354/index.md)","id":"CVE-2019-13354","markdown":"https://insights.sbomify.com/CVE-2019-13354/index.md","name":"CVE-2019-13354","record":{"aliases":["GHSA-5h5r-ffc4-c455"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby password gem","requires_auth":"none","summary":"A backdoor in the strong_password gem allows attackers to execute arbitrary code, requiring users to upgrade to a clean version.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"strong_password","vendor":"strong_password_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"The strong_password gem 0.0.7 for Ruby, as distributed on RubyGems.org, included a code-execution backdoor inserted by a third party. The current version, without this backdoor, is 0.0.6.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"strong_password Ruby gem malicious version causing Remote Code Execution vulnerability","id":"CVE-2019-13354","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"code_injection","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2019-13355"},"packages":[{"ecosystem":"RubyGems","fixed":["0.0.8"],"introduced":["0.0.7"],"last_affected":[],"package":"strong_password","purl":null,"source":"GHSA-5h5r-ffc4-c455"},{"ecosystem":"RubyGems","fixed":["0.0.8"],"introduced":["0.0.7"],"last_affected":[],"package":"strong_password","purl":"pkg:gem/strong_password","source":"GHSA-5h5r-ffc4-c455"}],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2019-13352"},"products":["n/a"],"published":"2019-07-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A backdoor in the strong_password gem allows attackers to execute arbitrary code, requiring users to upgrade to a clean version.","url":"https://insights.sbomify.com/CVE-2019-13354/"}