{"answers":{"affected":"2 open source packages ship an affected version, including phpbb/phpbb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-13376 in the wild and no public exploit code.","fix":"Upgrade phpbb/phpbb to 3.2.8 or later.","what":"CVE-2019-13376 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-13376 and fix it if it is affected.\n\nWhat it is: CVE-2019-13376 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-13376 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpbb/phpbb (Packagist): affected all versions; fixed in 3.2.8\n- phpbb/phpbb (Packagist): affected all versions; fixed in 3.2.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-13376/ (Markdown: https://insights.sbomify.com/CVE-2019-13376/index.md)","id":"CVE-2019-13376","markdown":"https://insights.sbomify.com/CVE-2019-13376/index.md","name":"CVE-2019-13376","record":{"aliases":["GHSA-6mh2-98gr-wv76","UBUNTU-CVE-2019-13376"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"phpBB forum software","requires_auth":"none","summary":"Attackers can steal admin session IDs via CSRF in the Remote Avatar feature, leading to stored XSS and potential administrative account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpbb","vendor":"phpbb"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"phpBB version 3.2.7 allows the stealing of an Administration Control Panel session id by leveraging CSRF in the Remote Avatar feature. The CSRF Token Hijacking leads to stored XSS","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpBB Cross-Site Request Forgery (CSRF)","id":"CVE-2019-13376","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Information disclosure in n/a","id":"CVE-2019-13377"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.8"],"introduced":["0"],"last_affected":[],"package":"phpbb/phpbb","purl":null,"source":"GHSA-6mh2-98gr-wv76"},{"ecosystem":"Packagist","fixed":["3.2.8"],"introduced":["0"],"last_affected":[],"package":"phpbb/phpbb","purl":"pkg:composer/phpbb/phpbb","source":"GHSA-6mh2-98gr-wv76"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2019-13375"},"products":["n/a"],"published":"2019-09-27","related":[{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2008-3224","kev_date_added":null,"published":"2008-07-18"},{"cvss_score":10,"headline":"Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack vectors, related to \"two minor security-related bu","id":"CVE-2008-1766","kev_date_added":null,"published":"2008-04-12"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2025-70810","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2001-1471","kev_date_added":null,"published":"2005-04-21"},{"cvss_score":8.1,"headline":"phpBB has Password Reset Link Poisoning via Host Header injection","id":"CVE-2026-29199","kev_date_added":null,"published":"2026-05-04"},{"cvss_score":7.5,"headline":"phpBB arbitrary CSS injection","id":"CVE-2019-16108","kev_date_added":null,"published":"2020-03-19"},{"cvss_score":7.5,"headline":"phpBB Denial of Service","id":"CVE-2019-9826","kev_date_added":null,"published":"2019-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can steal admin session IDs via CSRF in the Remote Avatar feature, leading to stored XSS and potential administrative account takeover.","url":"https://insights.sbomify.com/CVE-2019-13376/"}