# CVE-2019-13574: OS Command Injection in MiniMagick

> Attackers can execute arbitrary commands by providing a malicious filename to the MiniMagick library's image opening function.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-13574, DLA-1948-1, DSA-4481-1, GHSA-r7j3-vvh2-xrpj, OESA-2021-1150, UBUNTU-CVE-2019-13574

## What is CVE-2019-13574?

CVE-2019-13574 is a high-severity command injection vulnerability in Debian Debian Linux, published on 12 Jul 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In lib/mini_magick/image.rb in MiniMagick before 4.9.4, a fetched remote image filename could cause remote command execution because Image.open input is directly passed to Kernel#open, which accepts a '|' character followed by a command.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2019-13574?

2 open source packages ship an affected version, including mini_magick. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mini_magick` | RubyGems | All versions | 4.9.4 |
| `mini_magick` | RubyGems | All versions | 4.9.4 |

Products: Debian Debian Linux, Minimagick Project Minimagick.

## How do I fix CVE-2019-13574?

Upgrade mini_magick to 4.9.4 or later.

## Is CVE-2019-13574 being exploited?

There is no known exploitation of CVE-2019-13574 in the wild and no public exploit code.

Public exploit code:

- https://github.com/masahiro331/CVE-2019-13574 (github_poc): https://github.com/masahiro331/CVE-2019-13574

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13574 and fix it if it is affected.

What it is: CVE-2019-13574 is a high-severity command injection vulnerability in Debian Debian Linux, published on 12 Jul 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-13574 in the wild and no public exploit code.

Affected packages and fixed versions:
- mini_magick (RubyGems): affected all versions; fixed in 4.9.4
- mini_magick (RubyGems): affected all versions; fixed in 4.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13574/ (Markdown: https://insights.sbomify.com/CVE-2019-13574/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13574
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13574
- OSV: https://osv.dev/vulnerability/CVE-2019-13574

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13574/
Summaries are generated and may contain mistakes; the official description above is the record.
