# CVE-2019-13594: Mirumee Saleor CSRF Protection Disabled

> Attackers can perform unauthorized actions on behalf of users because CSRF protection was disabled in Saleor.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fgjh-x3f8-8gmh, PYSEC-2026-916

## What is CVE-2019-13594?

CVE-2019-13594 is a high-severity vulnerability in n/a, published on 14 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Mirumee Saleor 2.7.0 (fixed in 2.8.0), CSRF protection middleware was accidentally disabled, which allowed attackers to send a POST request without a valid CSRF token and be accepted by the server.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-13594?

3 open source packages ship an affected version, including saleor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `saleor` | PyPI | From 2.7.0 | 2.8.0 |
| `saleor` | PyPI | From 2.7.0 | 2.8.0 |
| `saleor` | PyPI | From 2.7.0 | 2.8.0 |

Products: Mirumee Saleor.

## How do I fix CVE-2019-13594?

Upgrade saleor to 2.8.0 or later.

## Is CVE-2019-13594 being exploited?

There is no known exploitation of CVE-2019-13594 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-15085](https://insights.sbomify.com/CVE-2020-15085/): Client caching login operation with plaintext password in Saleor Storefront (medium 6.9)
- [CVE-2020-7964](https://insights.sbomify.com/CVE-2020-7964/): Missing Authentication for Critical Function in Saleor (medium 5.3)
- [CVE-2019-1010304](https://insights.sbomify.com/CVE-2019-1010304/): Missing authorization in Saleor (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13594 and fix it if it is affected.

What it is: CVE-2019-13594 is a high-severity vulnerability in n/a, published on 14 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-13594 in the wild and no public exploit code.

Affected packages and fixed versions:
- saleor (PyPI): affected from 2.7.0; fixed in 2.8.0
- saleor (PyPI): affected from 2.7.0; fixed in 2.8.0
- saleor (PyPI): affected from 2.7.0; fixed in 2.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13594/ (Markdown: https://insights.sbomify.com/CVE-2019-13594/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13594
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13594
- OSV: https://osv.dev/vulnerability/CVE-2019-13594

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13594/
Summaries are generated and may contain mistakes; the official description above is the record.
