# CVE-2019-13628: wolfCrypt leaks cryptographic information via timing side channel

> A timing side channel in wolfSSL ECDSA signature generation allows local attackers to recover private keys via lattice attacks when specific math options are disabled.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-13628, GHSA-q95h-vc86-hv77, PYSEC-2026-1066, UBUNTU-CVE-2019-13628

## What is CVE-2019-13628?

CVE-2019-13628 is a medium-severity vulnerability in Wolfssl Wolfssl, published on 3 Oct 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

wolfSSL and wolfCrypt 4.0.0 and earlier (when configured without --enable-fpecc, --enable-sp, or --enable-sp-math) contain a timing side channel in ECDSA signature generation. This allows a local attacker, able to precisely measure the duration of signature operations, to infer information about the nonces used and potentially mount a lattice attack to recover the private key used. The issue occurs because ecc.c scalar multiplication might leak the bit length.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2019-13628?

3 open source packages ship an affected version, including wolfcrypt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wolfcrypt` | PyPI | All versions | 4.1.0 |
| `wolfcrypt` | PyPI | All versions | 4.1.0 |
| `wolfcrypt` | PyPI | All versions | 4.1.0 |

Products: Wolfssl Wolfssl.

## How do I fix CVE-2019-13628?

Upgrade wolfcrypt to 4.1.0 or later.

## Is CVE-2019-13628 being exploited?

There is no known exploitation of CVE-2019-13628 in the wild and no public exploit code.

## Other vulnerabilities in Wolfssl Wolfssl

- [CVE-2024-5991](https://insights.sbomify.com/CVE-2024-5991/): Buffer overread in domain name matching (critical 10.0)
- [CVE-2021-37155](https://insights.sbomify.com/CVE-2021-37155/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-36177](https://insights.sbomify.com/CVE-2020-36177/): Memory corruption in n/a (critical 9.8)
- [CVE-2014-2896](https://insights.sbomify.com/CVE-2014-2896/): Memory corruption in n/a (critical 9.8)
- [CVE-2014-2897](https://insights.sbomify.com/CVE-2014-2897/): Memory corruption in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13628 and fix it if it is affected.

What it is: CVE-2019-13628 is a medium-severity vulnerability in Wolfssl Wolfssl, published on 3 Oct 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-13628 in the wild and no public exploit code.

Affected packages and fixed versions:
- wolfcrypt (PyPI): affected all versions; fixed in 4.1.0
- wolfcrypt (PyPI): affected all versions; fixed in 4.1.0
- wolfcrypt (PyPI): affected all versions; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13628/ (Markdown: https://insights.sbomify.com/CVE-2019-13628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13628
- OSV: https://osv.dev/vulnerability/CVE-2019-13628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13628/
Summaries are generated and may contain mistakes; the official description above is the record.
