# CVE-2019-13645: Firefly III vulnerable to stored XSS

> Stored XSS in Firefly III allows attackers with equivalent access rights to execute JavaScript via malicious image filenames during attachment editing.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5hpw-vcj2-prwg

## What is CVE-2019-13645?

CVE-2019-13645 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Jul 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Firefly III before 4.7.17.3 is vulnerable to stored XSS due to lack of filtration of user-supplied data in image file names. The JavaScript code is executed during attachments/edit/$file_id$ attachment editing. NOTE: It is asserted that an attacker must have the same access rights as the user in order to be able to execute the vulnerability

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-13645?

2 open source packages ship an affected version, including grumpydictator/firefly-iii. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grumpydictator/firefly-iii` | Packagist | All versions | 4.7.17.3 |
| `grumpydictator/firefly-iii` | Packagist | All versions | 4.7.17.3 |

Products: Firefly-Iii Firefly Iii.

## How do I fix CVE-2019-13645?

Upgrade grumpydictator/firefly-iii to 4.7.17.3 or later.

## Is CVE-2019-13645 being exploited?

There is no known exploitation of CVE-2019-13645 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-0298](https://insights.sbomify.com/CVE-2023-0298/): Incorrect Authorization in firefly-iii/firefly-iii (medium 6.5)
- [CVE-2021-3728](https://insights.sbomify.com/CVE-2021-3728/): Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii (medium 6.5)
- [CVE-2021-3730](https://insights.sbomify.com/CVE-2021-3730/): Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii (medium 6.5)
- [CVE-2021-3846](https://insights.sbomify.com/CVE-2021-3846/): Unrestricted Upload of File with Dangerous Type in firefly-iii/firefly-iii (medium 6.3)
- [CVE-2024-22075](https://insights.sbomify.com/CVE-2024-22075/): Firefly III allows webhooks HTML Injection. (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13645 and fix it if it is affected.

What it is: CVE-2019-13645 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Jul 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-13645 in the wild and no public exploit code.

Affected packages and fixed versions:
- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 4.7.17.3
- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 4.7.17.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13645/ (Markdown: https://insights.sbomify.com/CVE-2019-13645/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13645
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13645
- OSV: https://osv.dev/vulnerability/CVE-2019-13645

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13645/
Summaries are generated and may contain mistakes; the official description above is the record.
