# CVE-2019-13915: b3log Wide unauthenticated file access

> Attackers can read or write arbitrary files via symlink manipulation in ZIP imports or Git repositories, or by executing code in the editor.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6452-jr93-r5qm, GO-2023-1924

## What is CVE-2019-13915?

CVE-2019-13915 is a high-severity path traversal vulnerability in n/a, published on 18 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

b3log Wide before 1.6.0 allows three types of attacks to access arbitrary files. First, the attacker can write code in the editor, and compile and run it approximately three times to read an arbitrary file. Second, the attacker can create a symlink, and then place the symlink into a ZIP archive. An unzip operation leads to read access, and write access (depending on file permissions), to the symlink target. Third, the attacker can import a Git repository that contains a symlink, similarly leading to read and write access.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2019-13915?

3 open source packages ship an affected version, including github.com/b3log/wide. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/b3log/wide` | Go | All versions | 1.6.0 |
| `github.com/b3log/wide` | Go | All versions | 1.6.0 |
| `github.com/b3log/wide` | Go | All versions | 1.6.0 |

Products: B3log Wide.

## How do I fix CVE-2019-13915?

Upgrade github.com/b3log/wide to 1.6.0 or later.

## Is CVE-2019-13915 being exploited?

There is no known exploitation of CVE-2019-13915 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13915 and fix it if it is affected.

What it is: CVE-2019-13915 is a high-severity path traversal vulnerability in n/a, published on 18 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-13915 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/b3log/wide (Go): affected all versions; fixed in 1.6.0
- github.com/b3log/wide (Go): affected all versions; fixed in 1.6.0
- github.com/b3log/wide (Go): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13915/ (Markdown: https://insights.sbomify.com/CVE-2019-13915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13915
- OSV: https://osv.dev/vulnerability/CVE-2019-13915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13915/
Summaries are generated and may contain mistakes; the official description above is the record.
