CVE-2019-13917 Code injection in n/a
Remote attackers can execute arbitrary code as root in Exim mail servers using specific non-default configurations involving the sort expansion.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-13917?
CVE-2019-13917 is a critical code injection vulnerability in Debian Debian Linux, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).
Weakness: CWE-19
Which versions are affected by CVE-2019-13917?
It affects 2 products.
Products include Debian Debian Linux, Exim Exim.
How do I fix CVE-2019-13917?
Upgrade to a fixed version.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2019-13917 being exploited?
There is no known exploitation of CVE-2019-13917 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2025-JY82846, DEBIAN-CVE-2019-13917, DSA-4488-1, GHSA-w2fj-xv79-84gh, UBUNTU-CVE-2019-13917, USN-4075-1.