# CVE-2019-13917: Code injection in n/a

> Remote attackers can execute arbitrary code as root in Exim mail servers using specific non-default configurations involving the sort expansion.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** CLEANSTART-2025-JY82846, DEBIAN-CVE-2019-13917, DSA-4488-1, GHSA-w2fj-xv79-84gh, UBUNTU-CVE-2019-13917, USN-4075-1

## What is CVE-2019-13917?

CVE-2019-13917 is a critical code injection vulnerability in Debian Debian Linux, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).

Weakness: CWE-19

## Which versions are affected by CVE-2019-13917?

It affects 2 products.


Products: Debian Debian Linux, Exim Exim.

## How do I fix CVE-2019-13917?

Upgrade to a fixed version.

## Is CVE-2019-13917 being exploited?

There is no known exploitation of CVE-2019-13917 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13917 and fix it if it is affected.

What it is: CVE-2019-13917 is a critical code injection vulnerability in Debian Debian Linux, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-13917 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13917/ (Markdown: https://insights.sbomify.com/CVE-2019-13917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13917
- OSV: https://osv.dev/vulnerability/CVE-2019-13917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13917/
Summaries are generated and may contain mistakes; the official description above is the record.
