{"answers":{"affected":"2 open source packages ship an affected version, including antsword. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-13970 in the wild and no public exploit code.","fix":"Upgrade antsword to 2.1.0 or later.","what":"CVE-2019-13970 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-13970 and fix it if it is affected.\n\nWhat it is: CVE-2019-13970 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-13970 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- antsword (npm): affected all versions; fixed in 2.1.0\n- antsword (npm): affected all versions; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-13970/ (Markdown: https://insights.sbomify.com/CVE-2019-13970/index.md)","id":"CVE-2019-13970","markdown":"https://insights.sbomify.com/CVE-2019-13970/index.md","name":"CVE-2019-13970","record":{"aliases":["GHSA-hq75-ggc3-8h3q"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"antSword web shell manager","requires_auth":"none","summary":"Self-XSS in antSword database configuration allows attackers to execute arbitrary code via malicious input in database settings.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"antsword","vendor":"antsword_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In antSword before 2.1.0, self-XSS in the database configuration leads to code execution via modules/database/asp/index.js, modules/database/custom/index.js, modules/database/index.js, or modules/database/php/index.js.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AntSword RCE and XSS via code injection","id":"CVE-2019-13970","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-13971"},"packages":[{"ecosystem":"npm","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"antsword","purl":null,"source":"GHSA-hq75-ggc3-8h3q"},{"ecosystem":"npm","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"antsword","purl":"pkg:npm/antsword","source":"GHSA-hq75-ggc3-8h3q"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2019-13969"},"products":["n/a"],"published":"2019-07-19","related":[{"cvss_score":9.6,"headline":"Cross-site scripting in n/a","id":"CVE-2020-18766","kev_date_added":null,"published":"2020-10-26"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2020-25470","kev_date_added":null,"published":"2020-10-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Self-XSS in antSword database configuration allows attackers to execute arbitrary code via malicious input in database settings.","url":"https://insights.sbomify.com/CVE-2019-13970/"}