# CVE-2019-13970: AntSword RCE and XSS via code injection

> Self-XSS in antSword database configuration allows attackers to execute arbitrary code via malicious input in database settings.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hq75-ggc3-8h3q

## What is CVE-2019-13970?

CVE-2019-13970 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In antSword before 2.1.0, self-XSS in the database configuration leads to code execution via modules/database/asp/index.js, modules/database/custom/index.js, modules/database/index.js, or modules/database/php/index.js.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-13970?

2 open source packages ship an affected version, including antsword. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `antsword` | npm | All versions | 2.1.0 |
| `antsword` | npm | All versions | 2.1.0 |

Products: Antsword Project Antsword.

## How do I fix CVE-2019-13970?

Upgrade antsword to 2.1.0 or later.

## Is CVE-2019-13970 being exploited?

There is no known exploitation of CVE-2019-13970 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-18766](https://insights.sbomify.com/CVE-2020-18766/): Cross-site scripting in n/a (critical 9.6)
- [CVE-2020-25470](https://insights.sbomify.com/CVE-2020-25470/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-13970 and fix it if it is affected.

What it is: CVE-2019-13970 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-13970 in the wild and no public exploit code.

Affected packages and fixed versions:
- antsword (npm): affected all versions; fixed in 2.1.0
- antsword (npm): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-13970/ (Markdown: https://insights.sbomify.com/CVE-2019-13970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-13970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-13970
- OSV: https://osv.dev/vulnerability/CVE-2019-13970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-13970/
Summaries are generated and may contain mistakes; the official description above is the record.
