CVE-2019-14232 Django Denial-of-service in django.utils.text.Truncator

High 7.5 Published Updated

Attackers can cause denial of service in Django applications by exploiting catastrophic backtracking in HTML truncation filters.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-14232?

CVE-2019-14232 is a high-severity denial of service vulnerability in Djangoproject Django, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x before 2.2.4. If django.utils.text.Truncator's chars() and words() methods were passed the html=True argument, they were extremely slow to evaluate certain inputs due to a catastrophic backtracking vulnerability in a regular expression. The chars() and words() methods are used to implement the truncatechars_html and truncatewords_html template filters, which were thus vulnerable.

Weakness: CWE-400

Which versions are affected by CVE-2019-14232?

7 open source packages ship an affected version, including django and Django. It affects 2 products.

PackageAffectedFixed in
django PyPIFrom 1.111.11.23, 2.1.11, 2.2.4
django PyPIFrom 1.11a11.11.23
django PyPIFrom 2.1a12.1.11
django PyPIFrom 2.2a12.2.4
Django PyPIFrom 1.11a11.11.23
Django PyPIFrom 2.1a12.1.11
1 more packages
Django PyPIFrom 2.2a12.2.4

Products include Djangoproject Django, Opensuse Leap.

How do I fix CVE-2019-14232?

Upgrade django to a fixed version for your release line: 1.11.23, 2.1.11 or 2.2.4.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2019-14232 being exploited?

There is no known exploitation of CVE-2019-14232 in the wild and no public exploit code.

All Djangoproject Django vulnerabilities

Sources

Also known as ALPINE-CVE-2019-14232, DEBIAN-CVE-2019-14232, GHSA-c4qh-4vgv-qc6g, PYSEC-2019-11, UBUNTU-CVE-2019-14232.

Is CVE-2019-14232 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free