# CVE-2019-14232: Django Denial-of-service in django.utils.text.Truncator

> Attackers can cause denial of service in Django applications by exploiting catastrophic backtracking in HTML truncation filters.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2019-14232, DEBIAN-CVE-2019-14232, GHSA-c4qh-4vgv-qc6g, PYSEC-2019-11, UBUNTU-CVE-2019-14232

## What is CVE-2019-14232?

CVE-2019-14232 is a high-severity denial of service vulnerability in Djangoproject Django, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x before 2.2.4. If django.utils.text.Truncator's chars() and words() methods were passed the html=True argument, they were extremely slow to evaluate certain inputs due to a catastrophic backtracking vulnerability in a regular expression. The chars() and words() methods are used to implement the truncatechars_html and truncatewords_html template filters, which were thus vulnerable.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2019-14232?

7 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.11 | 1.11.23, 2.1.11, 2.2.4 |
| `django` | PyPI | From 1.11a1 | 1.11.23 |
| `django` | PyPI | From 2.1a1 | 2.1.11 |
| `django` | PyPI | From 2.2a1 | 2.2.4 |
| `Django` | PyPI | From 1.11a1 | 1.11.23 |
| `Django` | PyPI | From 2.1a1 | 2.1.11 |
| `Django` | PyPI | From 2.2a1 | 2.2.4 |

Products: Djangoproject Django, Opensuse Leap.

## How do I fix CVE-2019-14232?

Upgrade django to a fixed version for your release line: 1.11.23, 2.1.11 or 2.2.4.

## Is CVE-2019-14232 being exploited?

There is no known exploitation of CVE-2019-14232 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14232 and fix it if it is affected.

What it is: CVE-2019-14232 is a high-severity denial of service vulnerability in Djangoproject Django, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14232 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 1.11; fixed in 1.11.23, 2.1.11, 2.2.4
- django (PyPI): affected from 1.11a1; fixed in 1.11.23
- django (PyPI): affected from 2.1a1; fixed in 2.1.11
- django (PyPI): affected from 2.2a1; fixed in 2.2.4
- Django (PyPI): affected from 1.11a1; fixed in 1.11.23
- Django (PyPI): affected from 2.1a1; fixed in 2.1.11
- Django (PyPI): affected from 2.2a1; fixed in 2.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14232/ (Markdown: https://insights.sbomify.com/CVE-2019-14232/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14232
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14232
- OSV: https://osv.dev/vulnerability/CVE-2019-14232

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14232/
Summaries are generated and may contain mistakes; the official description above is the record.
