# CVE-2019-14234: SQL Injection in Django

> Attackers can execute arbitrary SQL commands via crafted key lookups in Django's JSONField and HStoreField, potentially reading or modifying database records.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2019-14234, DEBIAN-CVE-2019-14234, GHSA-6r97-cj55-9hrq, PYSEC-2019-13, UBUNTU-CVE-2019-14234

## What is CVE-2019-14234?

CVE-2019-14234 is a critical SQL injection vulnerability in Debian Debian Linux, published on 9 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x before 2.2.4. Due to an error in shallow key transformation, key and index lookups for django.contrib.postgres.fields.JSONField, and key lookups for django.contrib.postgres.fields.HStoreField, were subject to SQL injection. This could, for example, be exploited via crafted use of "OR 1=1" in a key or index name to return all records, using a suitably crafted dictionary, with dictionary expansion, as the **kwargs passed to the QuerySet.filter() function.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2019-14234?

7 open source packages ship an affected version, including django and Django. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.11a1 | 1.11.23 |
| `django` | PyPI | From 2.1 | 2.1.11, 1.11.23, 2.2.4 |
| `django` | PyPI | From 2.1a1 | 2.1.11 |
| `django` | PyPI | From 2.2a1 | 2.2.4 |
| `Django` | PyPI | From 1.11a1 | 1.11.23 |
| `Django` | PyPI | From 2.1a1 | 2.1.11 |
| `Django` | PyPI | From 2.2a1 | 2.2.4 |

Products: Debian Debian Linux, Djangoproject Django, Fedoraproject Fedora.

## How do I fix CVE-2019-14234?

Upgrade django to a fixed version for your release line: 1.11.23, 2.1.11 or 2.2.4.

## Is CVE-2019-14234 being exploited?

There is no known exploitation of CVE-2019-14234 in the wild and no public exploit code.

Public exploit code:

- POC-Django JSONField/HStoreField SQL Injection Vulnerability (CVE-2019-14234) (github_poc): https://github.com/malvika-thakur/CVE-2019-14234

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14234 and fix it if it is affected.

What it is: CVE-2019-14234 is a critical SQL injection vulnerability in Debian Debian Linux, published on 9 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14234 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 1.11a1; fixed in 1.11.23
- django (PyPI): affected from 2.1; fixed in 2.1.11, 1.11.23, 2.2.4
- django (PyPI): affected from 2.1a1; fixed in 2.1.11
- django (PyPI): affected from 2.2a1; fixed in 2.2.4
- Django (PyPI): affected from 1.11a1; fixed in 1.11.23
- Django (PyPI): affected from 2.1a1; fixed in 2.1.11
- Django (PyPI): affected from 2.2a1; fixed in 2.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14234/ (Markdown: https://insights.sbomify.com/CVE-2019-14234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14234
- OSV: https://osv.dev/vulnerability/CVE-2019-14234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14234/
Summaries are generated and may contain mistakes; the official description above is the record.
