# CVE-2019-14235: Uncontrolled Recursion in Django

> Attackers can cause excessive memory consumption and service disruption in Django applications by sending specially crafted inputs to the URI encoding utility.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2019-14235, DEBIAN-CVE-2019-14235, GHSA-v9qg-3j8p-r63v, PYSEC-2019-14, UBUNTU-CVE-2019-14235

## What is CVE-2019-14235?

CVE-2019-14235 is a high-severity denial of service vulnerability in Djangoproject Django, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x before 2.2.4. If passed certain inputs, django.utils.encoding.uri_to_iri could lead to significant memory usage due to a recursion when repercent-encoding invalid UTF-8 octet sequences.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2019-14235?

7 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.11a1 | 1.11.23 |
| `django` | PyPI | From 2.1a1 | 2.1.11 |
| `django` | PyPI | From 2.2 | 2.2.4, 1.11.23, 2.1.11 |
| `django` | PyPI | From 2.2a1 | 2.2.4 |
| `Django` | PyPI | From 1.11a1 | 1.11.23 |
| `Django` | PyPI | From 2.1a1 | 2.1.11 |
| `Django` | PyPI | From 2.2a1 | 2.2.4 |

Products: Djangoproject Django, Opensuse Leap.

## How do I fix CVE-2019-14235?

Upgrade django to a fixed version for your release line: 1.11.23, 2.1.11 or 2.2.4.

## Is CVE-2019-14235 being exploited?

There is no known exploitation of CVE-2019-14235 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14235 and fix it if it is affected.

What it is: CVE-2019-14235 is a high-severity denial of service vulnerability in Djangoproject Django, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14235 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 1.11a1; fixed in 1.11.23
- django (PyPI): affected from 2.1a1; fixed in 2.1.11
- django (PyPI): affected from 2.2; fixed in 2.2.4, 1.11.23, 2.1.11
- django (PyPI): affected from 2.2a1; fixed in 2.2.4
- Django (PyPI): affected from 1.11a1; fixed in 1.11.23
- Django (PyPI): affected from 2.1a1; fixed in 2.1.11
- Django (PyPI): affected from 2.2a1; fixed in 2.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14235/ (Markdown: https://insights.sbomify.com/CVE-2019-14235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14235
- OSV: https://osv.dev/vulnerability/CVE-2019-14235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14235/
Summaries are generated and may contain mistakes; the official description above is the record.
