{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-14241 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2019-14241 is a high-severity denial of service vulnerability in n/a, published on 23 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-14241 and fix it if it is affected.\n\nWhat it is: CVE-2019-14241 is a high-severity denial of service vulnerability in n/a, published on 23 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-14241 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-14241/ (Markdown: https://insights.sbomify.com/CVE-2019-14241/index.md)","id":"CVE-2019-14241","markdown":"https://insights.sbomify.com/CVE-2019-14241/index.md","name":"CVE-2019-14241","record":{"aliases":["GHSA-rwrj-rg8q-w32h","SUSE-SU-2019:3001-1","SUSE-SU-2019:3002-1","openSUSE-SU-2019:2555-1","openSUSE-SU-2019:2556-1"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"HAProxy load balancer","requires_auth":"none","summary":"Attackers can cause a denial of service in HAProxy via specific cookie handling vectors, requiring administrators to apply vendor patches.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"haproxy","vendor":"haproxy"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"HAProxy through 2.0.2 allows attackers to cause a denial of service (ha_panic) via vectors related to htx_manage_client_side_cookies in proto_htx.c.","ecosystems":["SUSE:Linux Enterprise High Availability Extension 15","SUSE:Linux Enterprise High Availability Extension 15 SP1","openSUSE:Leap 15.0","openSUSE:Leap 15.1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2019-14241","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":4,"n_references":4,"next":{"headline":"Code injection in n/a","id":"CVE-2019-14242"},"packages":[{"ecosystem":"SUSE:Linux Enterprise High Availability Extension 15","fixed":["2.0.5+git0.d905f49a-3.12.6"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/suse/haproxy\u0026distro=SUSE%20Linux%20Enterprise%20High%20Availability%20Extension%2015","source":"SUSE-SU-2019:3002-1"},{"ecosystem":"SUSE:Linux Enterprise High Availability Extension 15 SP1","fixed":["2.0.5+git0.d905f49a-8.3.5"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/suse/haproxy\u0026distro=SUSE%20Linux%20Enterprise%20High%20Availability%20Extension%2015%20SP1","source":"SUSE-SU-2019:3001-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["2.0.5+git0.d905f49a-lp150.2.13.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/opensuse/haproxy\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:2555-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["2.0.5+git0.d905f49a-lp151.2.3.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/opensuse/haproxy\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2019:2556-1"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2019-14240"},"products":["n/a"],"published":"2019-07-23","related":[{"cvss_score":9,"headline":"HAProxy - Integer Overflow in FCGI Demux Record Length Field","id":"CVE-2026-55203","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":8.7,"headline":"HAProxy - NULL Pointer Dereference in hpack_dht_insert Function","id":"CVE-2026-55204","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":8.2,"headline":"Information disclosure in n/a","id":"CVE-2023-45539","kev_date_added":null,"published":"2023-11-28"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2024-45506","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":7.5,"headline":"Information disclosure in HAProxy","id":"CVE-2023-0836","kev_date_added":null,"published":"2023-03-29"},{"cvss_score":7.5,"headline":"Other in n/a","id":"CVE-2019-18277","kev_date_added":null,"published":"2019-10-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can cause a denial of service in HAProxy via specific cookie handling vectors, requiring administrators to apply vendor patches.","url":"https://insights.sbomify.com/CVE-2019-14241/"}