CVE-2019-14271 Moby Docker cp broken with debian containers
Attackers can execute arbitrary code by exploiting glibc nsswitch library loading within a Docker container chroot environment.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-14271?
CVE-2019-14271 is a critical code injection vulnerability in Debian Debian Linux, published on 29 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Docker 19.03.x before 19.03.1 linked against the GNU C Library (aka glibc), code injection can occur when the nsswitch facility dynamically loads a library inside a chroot that contains the contents of the container.
Weakness: CWE-665
Which versions are affected by CVE-2019-14271?
4 open source packages ship an affected version, including github.com/docker/docker and github.com/moby/moby. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/docker/docker Go | All versions | 20.10.0-beta1+incompatible |
github.com/docker/docker Go | From 19.03.0 | 19.03.1 |
github.com/docker/docker Go | From 19.03.0 | 19.03.1 |
github.com/moby/moby Go | All versions | 20.10.0-beta1+incompatible |
Products include Debian Debian Linux, Docker Docker, Opensuse Leap.
How do I fix CVE-2019-14271?
Upgrade github.com/docker/docker to a fixed version for your release line: 20.10.0-beta1+incompatible or 19.03.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2019-14271 being exploited?
There is no known exploitation of CVE-2019-14271 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-KW83332, DEBIAN-CVE-2019-14271, GHSA-v2cv-wwxq-qq97, GO-2024-2521.