# CVE-2019-14271: Moby Docker cp broken with debian containers

> Attackers can execute arbitrary code by exploiting glibc nsswitch library loading within a Docker container chroot environment.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** CLEANSTART-2026-KW83332, DEBIAN-CVE-2019-14271, GHSA-v2cv-wwxq-qq97, GO-2024-2521

## What is CVE-2019-14271?

CVE-2019-14271 is a critical code injection vulnerability in Debian Debian Linux, published on 29 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Docker 19.03.x before 19.03.1 linked against the GNU C Library (aka glibc), code injection can occur when the nsswitch facility dynamically loads a library inside a chroot that contains the contents of the container.

Weakness: CWE-665 (Improper Initialization)

## Which versions are affected by CVE-2019-14271?

4 open source packages ship an affected version, including github.com/docker/docker and github.com/moby/moby. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/docker/docker` | Go | All versions | 20.10.0-beta1+incompatible |
| `github.com/docker/docker` | Go | From 19.03.0 | 19.03.1 |
| `github.com/docker/docker` | Go | From 19.03.0 | 19.03.1 |
| `github.com/moby/moby` | Go | All versions | 20.10.0-beta1+incompatible |

Products: Debian Debian Linux, Docker Docker, Opensuse Leap.

## How do I fix CVE-2019-14271?

Upgrade github.com/docker/docker to a fixed version for your release line: 20.10.0-beta1+incompatible or 19.03.1.

## Is CVE-2019-14271 being exploited?

There is no known exploitation of CVE-2019-14271 in the wild and no public exploit code.

Public exploit code:

- A convenient and time-saving auto script of building environment and exploit it. (github_poc): https://github.com/LouisLiuNova/CVE-2019-14271_Exploit

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14271 and fix it if it is affected.

What it is: CVE-2019-14271 is a critical code injection vulnerability in Debian Debian Linux, published on 29 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14271 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/docker/docker (Go): affected all versions; fixed in 20.10.0-beta1+incompatible
- github.com/docker/docker (Go): affected from 19.03.0; fixed in 19.03.1
- github.com/docker/docker (Go): affected from 19.03.0; fixed in 19.03.1
- github.com/moby/moby (Go): affected all versions; fixed in 20.10.0-beta1+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14271/ (Markdown: https://insights.sbomify.com/CVE-2019-14271/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14271
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14271
- OSV: https://osv.dev/vulnerability/CVE-2019-14271

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14271/
Summaries are generated and may contain mistakes; the official description above is the record.
