# CVE-2019-14322: Pallets Werkzeug vulnerable to Path Traversal

> Attackers can bypass path restrictions in SharedDataMiddleware on Windows to read arbitrary files via crafted drive names.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-j544-7q9p-6xp8, PYSEC-2026-1065

## What is CVE-2019-14322?

CVE-2019-14322 is a high-severity path traversal vulnerability in n/a, published on 28 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Pallets Werkzeug before 0.15.5, SharedDataMiddleware mishandles drive names (such as C:) in Windows pathnames.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-14322?

3 open source packages ship an affected version, including werkzeug. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `werkzeug` | PyPI | All versions | 0.15.5 |
| `werkzeug` | PyPI | All versions | 0.15.5 |
| `werkzeug` | PyPI | All versions | 0.15.5 |

Products: Palletsprojects Werkzeug.

## How do I fix CVE-2019-14322?

Upgrade werkzeug to 0.15.5 or later.

## Is CVE-2019-14322 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-14322 exists.

Public exploit code:

- PoC of CVE-2019-14322: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (github_poc): https://github.com/faisalfs10x/CVE-2019-14322-scanner
- Nmap NSE script to detect CVE-2019-14322 of Pallets Werkzeug path traversal via SharedDataMiddleware mishandles drive names (such as C:) in Windows pathnames (github_poc): https://github.com/faisalfs10x/http-vuln-cve2019-14322.nse
- Modification of: PoC of CVE-2019-14322: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (github_poc): https://github.com/sergiovks/CVE-2019-14322
- Pallets Werkzeug 0.15.4 - Path Traversal (exploitdb)
- Pallets Werkzeug <0.15.5 - Local File Inclusion (nuclei): http/cves/2019/CVE-2019-14322.yaml

## Other vulnerabilities in n/a

- [CVE-2022-29361](https://insights.sbomify.com/CVE-2022-29361/): Other in n/a (critical 9.8)
- [CVE-2023-46136](https://insights.sbomify.com/CVE-2023-46136/): Werkzeug DoS: High resource usage when parsing multipart/form-data containing a large part with CR/LF character at the beginning (high 8.0)
- [CVE-2023-25577](https://insights.sbomify.com/CVE-2023-25577/): Werkzeug may allow high resource usage when parsing multipart form data with many fields (high 7.5)
- [CVE-2026-27199](https://insights.sbomify.com/CVE-2026-27199/): Werkzeug safe_join() allows Windows special device names (medium 6.3)
- [CVE-2026-21860](https://insights.sbomify.com/CVE-2026-21860/): Werkzeug safe_join() allows Windows special device names with compound extensions (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14322 and fix it if it is affected.

What it is: CVE-2019-14322 is a high-severity path traversal vulnerability in n/a, published on 28 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-14322 exists.

Affected packages and fixed versions:
- werkzeug (PyPI): affected all versions; fixed in 0.15.5
- werkzeug (PyPI): affected all versions; fixed in 0.15.5
- werkzeug (PyPI): affected all versions; fixed in 0.15.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14322/ (Markdown: https://insights.sbomify.com/CVE-2019-14322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14322
- OSV: https://osv.dev/vulnerability/CVE-2019-14322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14322/
Summaries are generated and may contain mistakes; the official description above is the record.
