CVE-2019-14492 Out-of-bounds Read and Out-of-bounds Write in OpenCV
An out-of-bounds read/write in OpenCV's HaarEvaluator allows attackers to cause a denial of service via crafted input.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-14492?
CVE-2019-14492 is a high-severity memory corruption vulnerability in Opensuse Leap, published on 1 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in OpenCV before 3.4.7 and 4.x before 4.1.1. There is an out of bounds read/write in the function HaarEvaluator::OptFeature::calc in modules/objdetect/src/cascadedetect.hpp, which leads to denial of service.
Which versions are affected by CVE-2019-14492?
20 open source packages ship an affected version, including opencv-contrib-python, opencv-contrib-python-headless and opencv-python. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
opencv-contrib-python PyPI | All versions | 3.4.7.28, 4.1.1.26 |
opencv-contrib-python PyPI | All versions | 3.4.7.28 |
opencv-contrib-python PyPI | All versions | 3.4.7.28 |
opencv-contrib-python PyPI | From 4.0.0.21 | 4.1.1.26 |
opencv-contrib-python PyPI | From 4.0.0.21 | 4.1.1.26 |
opencv-contrib-python-headless PyPI | All versions | 3.4.7.28, 4.1.1.26 |
14 more packages
opencv-contrib-python-headless PyPI | All versions | 3.4.7.28 |
opencv-contrib-python-headless PyPI | All versions | 3.4.7.28 |
opencv-contrib-python-headless PyPI | From 4.0.0.21 | 4.1.1.26 |
opencv-contrib-python-headless PyPI | From 4.0.0.21 | 4.1.1.26 |
opencv-python PyPI | All versions | 3.4.7.28, 4.1.1.26 |
opencv-python PyPI | All versions | 3.4.7.28 |
opencv-python PyPI | All versions | 3.4.7.28 |
opencv-python PyPI | From 4.0.0.21 | 4.1.1.26 |
opencv-python PyPI | From 4.0.0.21 | 4.1.1.26 |
opencv-python-headless PyPI | All versions | 3.4.7.28, 4.1.1.26 |
opencv-python-headless PyPI | All versions | 3.4.7.28 |
opencv-python-headless PyPI | All versions | 3.4.7.28 |
opencv-python-headless PyPI | From 4.0.0.21 | 4.1.1.26 |
opencv-python-headless PyPI | From 4.0.0.21 | 4.1.1.26 |
Products include Opencv Opencv, Opensuse Leap.
How do I fix CVE-2019-14492?
Upgrade opencv-contrib-python to a fixed version for your release line: 3.4.7.28 or 4.1.1.26.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2019-14492 being exploited?
There is no known exploitation of CVE-2019-14492 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Leap
Sources
Also known as DEBIAN-CVE-2019-14492, GHSA-fw99-f933-rgh8, PYSEC-2026-2798, PYSEC-2026-2821, PYSEC-2026-2837, PYSEC-2026-721 and 1 more.