CVE-2019-14537 Access of Resource Using Incompatible Type ('Type Confusion') in yourls/yourls

Critical 9.8 Published Updated

Attackers can bypass login via type juggling in the API, allowing unauthorized access to YOURLS accounts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-14537?

CVE-2019-14537 is a critical authentication bypass vulnerability in n/a, published on 7 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

YOURLS through 1.7.3 is affected by a type juggling vulnerability in the api component that can result in login bypass.

Weakness: CWE-843

Which versions are affected by CVE-2019-14537?

2 open source packages ship an affected version, including yourls/yourls. It affects 1 product.

PackageAffectedFixed in
yourls/yourls PackagistAll versions1.7.4
yourls/yourls PackagistAll versions1.7.4

Products include Yourls Yourls.

How do I fix CVE-2019-14537?

Upgrade yourls/yourls to 1.7.4 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2019-14537 being exploited?

There is no known exploitation of CVE-2019-14537 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-vf23-f26f-mjj9.

Is CVE-2019-14537 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free