CVE-2019-14540 Polymorphic Typing issue in FasterXML jackson-databind
Attackers can execute arbitrary code via unsafe deserialization in the jackson-databind library when handling specific polymorphic types.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-14540?
CVE-2019-14540 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 15 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A Polymorphic Typing issue was discovered in FasterXML jackson-databind before 2.9.10. It is related to com.zaxxer.hikari.HikariConfig.
Weakness: CWE-502
Which versions are affected by CVE-2019-14540?
6 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 19 products.
| Package | Affected | Fixed in |
|---|---|---|
com.fasterxml.jackson.core:jackson-databind Maven | All versions | 2.6.7.3 |
com.fasterxml.jackson.core:jackson-databind Maven | All versions | 2.6.7.3 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.7.0 | 2.8.11.5 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.7.0 | 2.8.11.5 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.10 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.10 |
Products include Debian Debian Linux, Fasterxml Jackson-Databind, Fedoraproject Fedora, Netapp Oncommand Api Services, Netapp Oncommand Workflow Automation, Netapp Steelstore Cloud Integrated Storage and 13 more.
How do I fix CVE-2019-14540?
Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.6.7.3, 2.8.11.5 or 2.9.10.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2019-14540 being exploited?
There is no known exploitation of CVE-2019-14540 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-UF85195, DEBIAN-CVE-2019-14540, GHSA-h822-r4r5-v8jg, ROOT-APP-MAVEN-CVE-2019-14540, UBUNTU-CVE-2019-14540.