# CVE-2019-14540: Polymorphic Typing issue in FasterXML jackson-databind

> Attackers can execute arbitrary code via unsafe deserialization in the jackson-databind library when handling specific polymorphic types.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2019
- **Updated:** 8 Oct 2026
- **Also known as:** CLEANSTART-2026-UF85195, DEBIAN-CVE-2019-14540, GHSA-h822-r4r5-v8jg, ROOT-APP-MAVEN-CVE-2019-14540, UBUNTU-CVE-2019-14540

## What is CVE-2019-14540?

CVE-2019-14540 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 15 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Polymorphic Typing issue was discovered in FasterXML jackson-databind before 2.9.10. It is related to com.zaxxer.hikari.HikariConfig.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2019-14540?

6 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 19 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | All versions | 2.6.7.3 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | All versions | 2.6.7.3 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.7.0 | 2.8.11.5 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.7.0 | 2.8.11.5 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.10 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.10 |

Products: Debian Debian Linux, Fasterxml Jackson-Databind, Fedoraproject Fedora, Netapp Oncommand Api Services, Netapp Oncommand Workflow Automation, Netapp Steelstore Cloud Integrated Storage, Oracle Banking Platform, Oracle Customer Management and Segmentation Foundation, Oracle Financial Services Analytical Applications Infrastructure, Oracle Global Lifecycle Management Opatch, Oracle Goldengate Application Adapters, Oracle Goldengate Stream Analytics, Oracle Mysql, Oracle Primavera Gateway, Oracle Primavera Unifier, Oracle Retail Customer Management and Segmentation Foundation, Oracle Retail Xstore Point of Service, Oracle Weblogic Server, Redhat Jboss Enterprise Application Platform.

## How do I fix CVE-2019-14540?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.6.7.3, 2.8.11.5 or 2.9.10.

## Is CVE-2019-14540 being exploited?

There is no known exploitation of CVE-2019-14540 in the wild and no public exploit code.

Public exploit code:

- CVE-2019-14540 Exploit (github_poc): https://github.com/LeadroyaL/cve-2019-14540-exploit

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14540 and fix it if it is affected.

What it is: CVE-2019-14540 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 15 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14540 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.fasterxml.jackson.core:jackson-databind (Maven): affected all versions; fixed in 2.6.7.3
- com.fasterxml.jackson.core:jackson-databind (Maven): affected all versions; fixed in 2.6.7.3
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.7.0; fixed in 2.8.11.5
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.7.0; fixed in 2.8.11.5
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.10
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14540/ (Markdown: https://insights.sbomify.com/CVE-2019-14540/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14540
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14540
- OSV: https://osv.dev/vulnerability/CVE-2019-14540

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14540/
Summaries are generated and may contain mistakes; the official description above is the record.
