CVE-2019-14671 Improper Input Validation in Firefly III

Low 3.3 Published Updated

An attacker can enumerate local files in Firefly III due to insufficient sanitization of file protocol schemes in import configurations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2019-14671?

CVE-2019-14671 is a low-severity path traversal vulnerability in n/a, published on 5 Aug 2019. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Firefly III 4.7.17.3 is vulnerable to local file enumeration. An attacker can enumerate local files due to the lack of protocol scheme sanitization, such as for file:/// URLs. This is related to fints_url to import/job/configuration, and import/create/fints.

Weakness: CWE-20

Which versions are affected by CVE-2019-14671?

2 open source packages ship an affected version, including grumpydictator/firefly-iii. It affects 1 product.

PackageAffectedFixed in
grumpydictator/firefly-iii PackagistAll versions4.7.17.4
grumpydictator/firefly-iii PackagistAll versions4.7.17.4

Products include Firefly-Iii Firefly Iii.

How do I fix CVE-2019-14671?

Upgrade grumpydictator/firefly-iii to 4.7.17.4 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2019-14671 being exploited?

There is no known exploitation of CVE-2019-14671 in the wild and no public exploit code.

Sources

Also known as GHSA-jjcx-999m-35hc.

Is CVE-2019-14671 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free