{"answers":{"affected":"2 open source packages ship an affected version, including grumpydictator/firefly-iii. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-14671 in the wild and no public exploit code.","fix":"Upgrade grumpydictator/firefly-iii to 4.7.17.4 or later.","what":"CVE-2019-14671 is a low-severity path traversal vulnerability in n/a, published on 5 Aug 2019. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-14671 and fix it if it is affected.\n\nWhat it is: CVE-2019-14671 is a low-severity path traversal vulnerability in n/a, published on 5 Aug 2019. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-14671 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 4.7.17.4\n- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 4.7.17.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-14671/ (Markdown: https://insights.sbomify.com/CVE-2019-14671/index.md)","id":"CVE-2019-14671","markdown":"https://insights.sbomify.com/CVE-2019-14671/index.md","name":"CVE-2019-14671","record":{"aliases":["GHSA-jjcx-999m-35hc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Firefly III","requires_auth":"low_privilege","summary":"An attacker can enumerate local files in Firefly III due to insufficient sanitization of file protocol schemes in import configurations.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"firefly_iii","vendor":"firefly-iii"}],"cvss":{"score":3.3,"severity":"low","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Firefly III 4.7.17.3 is vulnerable to local file enumeration. An attacker can enumerate local files due to the lack of protocol scheme sanitization, such as for file:/// URLs. This is related to fints_url to import/job/configuration, and import/create/fints.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in Firefly III","id":"CVE-2019-14671","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-14672"},"packages":[{"ecosystem":"Packagist","fixed":["4.7.17.4"],"introduced":["0"],"last_affected":[],"package":"grumpydictator/firefly-iii","purl":null,"source":"GHSA-jjcx-999m-35hc"},{"ecosystem":"Packagist","fixed":["4.7.17.4"],"introduced":["0"],"last_affected":[],"package":"grumpydictator/firefly-iii","purl":"pkg:composer/grumpydictator/firefly-iii","source":"GHSA-jjcx-999m-35hc"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-14670"},"products":["n/a"],"published":"2019-08-05","related":[{"cvss_score":6.5,"headline":"Incorrect Authorization in firefly-iii/firefly-iii","id":"CVE-2023-0298","kev_date_added":null,"published":"2023-01-14"},{"cvss_score":6.5,"headline":"Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii","id":"CVE-2021-3728","kev_date_added":null,"published":"2021-08-23"},{"cvss_score":6.5,"headline":"Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii","id":"CVE-2021-3730","kev_date_added":null,"published":"2021-08-23"},{"cvss_score":6.3,"headline":"Unrestricted Upload of File with Dangerous Type in firefly-iii/firefly-iii","id":"CVE-2021-3846","kev_date_added":null,"published":"2021-10-19"},{"cvss_score":6.1,"headline":"Firefly III allows webhooks HTML Injection.","id":"CVE-2024-22075","kev_date_added":null,"published":"2024-01-05"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2019-14667","kev_date_added":null,"published":"2019-08-05"},{"cvss_score":5.4,"headline":"Insufficient Session Expiration in firefly-iii/firefly-iii","id":"CVE-2023-1788","kev_date_added":null,"published":"2023-04-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can enumerate local files in Firefly III due to insufficient sanitization of file protocol schemes in import configurations.","url":"https://insights.sbomify.com/CVE-2019-14671/"}