# CVE-2019-14671: Improper Input Validation in Firefly III

> An attacker can enumerate local files in Firefly III due to insufficient sanitization of file protocol schemes in import configurations.

- **Severity:** Low 3.3 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jjcx-999m-35hc

## What is CVE-2019-14671?

CVE-2019-14671 is a low-severity path traversal vulnerability in n/a, published on 5 Aug 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Firefly III 4.7.17.3 is vulnerable to local file enumeration. An attacker can enumerate local files due to the lack of protocol scheme sanitization, such as for file:/// URLs. This is related to fints_url to import/job/configuration, and import/create/fints.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2019-14671?

2 open source packages ship an affected version, including grumpydictator/firefly-iii. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grumpydictator/firefly-iii` | Packagist | All versions | 4.7.17.4 |
| `grumpydictator/firefly-iii` | Packagist | All versions | 4.7.17.4 |

Products: Firefly-Iii Firefly Iii.

## How do I fix CVE-2019-14671?

Upgrade grumpydictator/firefly-iii to 4.7.17.4 or later.

## Is CVE-2019-14671 being exploited?

There is no known exploitation of CVE-2019-14671 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-0298](https://insights.sbomify.com/CVE-2023-0298/): Incorrect Authorization in firefly-iii/firefly-iii (medium 6.5)
- [CVE-2021-3728](https://insights.sbomify.com/CVE-2021-3728/): Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii (medium 6.5)
- [CVE-2021-3730](https://insights.sbomify.com/CVE-2021-3730/): Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii (medium 6.5)
- [CVE-2021-3846](https://insights.sbomify.com/CVE-2021-3846/): Unrestricted Upload of File with Dangerous Type in firefly-iii/firefly-iii (medium 6.3)
- [CVE-2024-22075](https://insights.sbomify.com/CVE-2024-22075/): Firefly III allows webhooks HTML Injection. (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14671 and fix it if it is affected.

What it is: CVE-2019-14671 is a low-severity path traversal vulnerability in n/a, published on 5 Aug 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14671 in the wild and no public exploit code.

Affected packages and fixed versions:
- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 4.7.17.4
- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 4.7.17.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14671/ (Markdown: https://insights.sbomify.com/CVE-2019-14671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14671
- OSV: https://osv.dev/vulnerability/CVE-2019-14671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14671/
Summaries are generated and may contain mistakes; the official description above is the record.
